Problem faced:
The shortcut is creating temporary runtime entries when launched (i.e the files are created and gets deleted automatically once you exit the app). I added those files in sft and published it on client the application loads successfully but it throws an error when launched saying that files under certain location could not opened Check if the files exist and you are pemitted to read these files.

The files which are getting created on runtime requires permission, how to i handle this in SoftGrid as it works fine when repackaged after adding and giving permission to those files.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I faced a similar permissions issue problem while sequencing Firefox - I changed the security permissions to the Mozilla top-level directory & registry tree to 'Authenticated Users' = Modified while I was capturing the install.
Answered 04/23/2008 by: BadShadd
Orange Senior Belt

Please log in to comment
0
Thanks for sharing it, i will try it at my end hope it works.
Answered 04/28/2008 by: shweta_kar
Blue Belt

Please log in to comment
0
Hi Badshadd,

I tried giving permission to the root level directory but it dint work for me and threw these error stating unable to read the file.

I repackaged the application, it works fine when we add the runtime entries and give permission to C:windows\system32\app folder , so while sequencing i installed the repackaged msi instead of setup, but in vain

Is there any other trouble shooting method while handling permission in softgrid.
Answered 05/01/2008 by: shweta_kar
Blue Belt

Please log in to comment
0
I didn't say root level directory, I said 'Mozilla top-level directory' or Q:\Firefox.v13\Mozilla Firefox\ (if this is where you installed to) & HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla.

[font="times new roman"]Try making the security changes at these locations & use 'Authenticated Users' = Modify permissions.
Answered 05/04/2008 by: BadShadd
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity