I've installed adobe flash 11.2 and then noticed that every computer in the company has scheduler task to check for adobe updates every hour! I removed this task from all computers, but now I want to update flash again, and when I am updating it this task is popping up again. Is there a way to disable it?

I've got mms.cfg file with AutoUpdateDisable=1 in it. It is copied to every computer during install. It is saved as UTF-8. I've never had this problem with previous flash updates.

Does anyone else have the same problem?

Tanya

 

Answer Summary:
This can be done with the .exe installer by using the command line argument "-install -au 2" The MSI installer can be similarly configured with an MST transform file by using a tool such as Microsoft Orca to add the -au 2 command line parameter. The setting is under "CustomAction" table. Add -au 2 to the command line parameter in the "NewCustomAction1" setting. See http://robotarchive.blogspot.com/2015/01/package-adobe-flash-player-in-sccm-with.html for a walkthrough.
Cancel
1 Comment   [ + ] Show Comment

Comments

  • Trying to use local update publisher to deploy Flash through WSUS. I'm using ORCA to recreate the msi and have followed these steps:
    The 2 things I change in the MST that prevents updates are shown below:
    Properties:
    AgreeToLicense = Yes
    ISCHECKFORPRODUCTUPDATES = 0
    CheckBox:
    ISCHECKFORPRODUCTUPDATES = 0

    The installer just blows up on me. Help Please
Please log in to comment

Community Chosen Answer

4

If you select the option to disable auto updates the service or task should no longer be created (previous versions created the scheduled task regardless). The only issue is that this is only true if you install Flash via the GUI and there currently isnt an option for this when you want to silently install. http://blogs.adobe.com/spohl/2012/05/04/changes-to-adobe-flash-player-background-updater/

UPDATE: I actually just discovered that this can be done with the .exe installer by using the command line argument "-install -au 2". I found this info from a comment by Stephen Pohl here: http://www.gregorystrike.com/2012/05/15/the-adobe-flash-player-update-service-starts-up-every-hour/

Answered 05/24/2012 by: Capital__
Orange Belt

  • Thank you Capital__
Please log in to comment

Answers

3

To remove Adobe's scheduled task, just go to 'Execute Deferred' and in the line 'Execute Installed Program InstallAX.exe ... just add '-au 2' so the 'Command Line Arguments' line will be:
-install -msi -au 2

Answered 05/29/2012 by: k8tb
White Belt

Please log in to comment
2
@ECHO OFF
REM kills and removes Adobe Updater services and tasks

REM Stop Adobe Flash Player Updater service
net stop AdobeFlashPlayerUpdateSvc
net stop AdobeARMservice

REM Stop Adobe Flash Player Updater task
SCHTASKS /End /TN "Adobe Flash Player Updater"

REM Disable the services
sc config AdobeFlashPlayerUpdateSvc start= disabled
sc config AdobeARMservice start= disabled

REM deletes the service
sc delete AdobeFlashPlayerUpdateSvc
sc delete AdobeARMservice

REM Disable the task
SCHTASKS /Change /TN "Adobe Flash Player Updater" /DISABLE

REM Delete the task
SCHTASKS /Delete /TN "Adobe Flash Player Updater" /F

REM Adobe Updater RIP
Answered 05/12/2015 by: MattClayton
White Belt

Please log in to comment
2

The properties that you need to set is:

AutoUpdateDisable=1

SilentAutoUpdateEnable=0

The updater would run every hour but it wont download any updates. You can use a network analyser tool to check this.

 

 

Answered 05/10/2012 by: adilrathore
Fourth Degree Black Belt

  • Thank you very much for reply Adilrathore. But do you know is there any way to disable this updater completely. Don't really want something unnecessary to run every hour in every computer in the company
    With a previous update I removed scheduler task as a separate step, but was wondering is there any way to not install it in the first place.
Please log in to comment
1

I have faced the same problem. After doing changes in mms file still Adobe flash was checking for update as it was not disabled. Later on on a query with client , theuy contacted with Adobe and told us that there is bug in Adobe Flash 11. 

The mms file settings works file in Adobe Flash 10.*.* but it won't work in later versions....

Answered 07/25/2012 by: vmnit
Third Degree Blue Belt

Please log in to comment
0

You can use Adobe's Customization Tool to modify the MSI that disables these processes on install.  The Customization Tool is similar to ORCA but allows the creation of a modified MSI file.

Answered 05/12/2012 by: Trinity
Brown Belt

  • Trinity, can you use Adobe customization tool for Flash? I've checked Adobe customization wizard 9 and 10 and they both only for Reader and Acrobat. I've tried to open flash msi, but got error.
  • If the Customization tool from Adobe is causing errors. You can also try using Orca. They provide the same function but orca works with almost all MSI's:
    http://blogs.technet.com/b/bernhard_frank/archive/2010/03/15/how-to-install-orca-exe-from-the-windows-installer-development-tools.aspx
  • Trinity, I've tried Orca and Admin Studio already, but couldn't find option to disable this updater. as part of the update I always create mst file using admin studio and change two parameters there:
    IScheckforproductupdate – 0
    Agree ToLicense – yes
    Also I add mms.cfg file to the flash directory.
    • Tanya, the easiest way with Orca is to make a single edit to the command line parameter passed to the installer. The -au 2 flag, when passed to the installer, causes it to create an mms.cfg file for you with the proper settings to disable automatic updates. See http://robotarchive.blogspot.com/2015/01/package-adobe-flash-player-in-sccm-with.html for details.
  • The 2 things I change in the MST that prevents updates are shown below:
    Properties:
    AgreeToLicense = Yes
    ISCHECKFORPRODUCTUPDATES = 0
    CheckBox:
    ISCHECKFORPRODUCTUPDATES = 0

    You can check this by checking the Flash Player Component that is now located in Control Panel after install. The Advanced tab should show. Never check for updates (not recommended)
  • I've checked Advanced tab and it is showing up as never check for updates.

    But nevertheless I still have scheduler task on every computer to look for update every hour. Maybe it is actually doesn't look for updates and maybe it is not going to download updates, but it runs every hour! I can see it run in the event log. So this is what I what to disable, don't see a need for that to run, especially every hour. I deleted this service and scheduler task as a separate step, but was wondering if it is possible to do it in one go, and somehow not to install this updater at all in the first place.


    Log Name: System
    Source: Service Control Manager
    Date: 09/05/2012 15:00:43
    Event ID: 7036
    Task Category: None
    Level: Information
    Keywords: Classic
    User: N/A
    Computer: xxx
    Description:
    The Adobe Flash Player Update Service service entered the running state.
Please log in to comment
Answer this question or Comment on this question for clarity