When i set the property arporemove=1 also it is is enable.Please reply me how to solve this issue. 

Answer Summary:
ARPNOREMOVE=1
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1

Verify if the property is spelled correctly, it should be ARPNOREMOVE=1, with capital letters. If is corect, then you have to check if you have in the package some other Uninstall registry entries. Remove all registry entrys related to Uninstall and add the Add/Remove entry again. You should have only one registry entry related to uninstall.

 

Answered 05/14/2013 by: terebent
Brown Belt

Please log in to comment
1

Not sure how this equates to 'Virtualization' that you've tagged this post for...

ARPNOREMOVE=1 is the Public Property you're looking for to add to the Property Table of an MSI or MST to disable the remove button in ARP - note the spelling, and the capitalisation of the letters - they are important.

Its cousins, ARPNOMODIFY and ARPNOREPAIR are also useful.

 

Dunnpy

Answered 05/07/2013 by: dunnpy
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity