Hi all,

We are facing a very tiresome situation here. We have Quicktime 6.0.2 installed company-wide and we need to change a setting in the Browser Plugin section. Basically, we need to remove the association to TIF/TIFF files. I have tried simply deleting the registry keys that appear to be associated but the settings do not seem to take effect (you have to start the QT player, go into the settings and click OK!).

Our last resort is to amend the original MSI file and re-install it company-wide WITHOUT the TIF/TIFF association and I was wondering if anyone had experimented with this and figured out what registry/file system changes need to be made?

Any help appreciated
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
If you delete it from the registy, will if then be back? (thinking of the Self healing)

If this is the case, modify the original package, and sent it out again. with the commands REINSTALL=ALL REINSTALLMODE=VOMUS.

You can also do a snapshot to see what happens when you delete tha association.

//Göran
Answered 02/16/2005 by: fetgor
Senior Purple Belt

Please log in to comment
0
Hi,

I have had the same issues with QT. I have created the following .reg file from my investigations (I have been unable to test this myself due to infrastructure issues)

Also, QT saves its preferences in the following file: documents and settings\all users\application data\quicktime\quicktime.qtp

I suggest trying the registry (please have a look and determine if this will mess up anything else you have) and copying a version of the .qtp file with the .tiff association turned off.

Good luck.
------------------------------------------
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/x-tiff]
[HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/x-tiff]
"extension"=".tif"

[-HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/tiff]
[HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/tiff]
"AutoplayContentTypeHandler"="PicturesContentHandler"
"extension"=".tif"

[-HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\Installed MIME Types]
[HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\Installed MIME Types]
"video/quicktime"="mov,qt"
"image/x-macpaint"="pntg,pnt,mac"
"image/x-quicktime"="qtif,qti"
"application/sdp"="sdp"
"application/x-sdp"="sdp"
"application/x-rtsp"="rtsp,rts"
"video/flc"="flc,fli"
"audio/x-wav"="wav,bwf"
"audio/wav"="wav,bwf"
"audio/aiff"="aiff,aif,aifc,cdda"
"audio/x-aiff"="aiff,aif,aifc,cdda"
"audio/basic"="au,snd,ulw"
"audio/mid"="mid,midi,smf,kar"
"audio/x-midi"="mid,midi,smf,kar"
"audio/midi"="mid,midi,smf,kar"
"audio/vnd.qcelp"="qcp"
"audio/AMR"="AMR"
"audio/x-gsm"="gsm"
"video/x-mpeg"="mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa"
"video/mpeg"="mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa"
"audio/mpeg"="mpeg,mpg,m1s,m1a,mp2,mpm,mpa"
"audio/x-mpeg"="mpeg,mpg,m1s,m1a,mp2,mpm,mpa"
"video/3gpp"="3gp,3gpp"
"audio/3gpp"="3gp,3gpp"
"video/3gpp2"="3g2,3gp2"
"audio/3gpp2"="3g2,3gp2"
"video/mp4"="mp4,mpg4"
"audio/mp4"="mp4,mpg4"
"audio/x-m4a"="m4a"
"audio/x-m4p"="m4p"
"audio/x-m4b"="m4b"
"video/x-m4v"="m4v"
"video/sd-video"="sdv"
"application/x-mpeg"="amc"
"image/pict"="pict,pic,pct"
"image/x-pict"="pict,pic,pct"
"image/png"="png"
"image/x-png"="png"
"image/x-sgi"="sgi,rgb"
"image/x-targa"="targa,tga"

[-HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\ActiveX\Installed MIME Types]
[HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\ActiveX\Installed MIME Types]
"video/quicktime"="mov,qt"
"image/x-macpaint"="pntg,pnt,mac"
"image/x-quicktime"="qtif,qti"
"application/sdp"="sdp"
"application/x-sdp"="sdp"
"application/x-rtsp"="rtsp,rts"
"video/flc"="flc,fli"
"audio/x-wav"="wav,bwf"
"audio/wav"="wav,bwf"
"audio/aiff"="aiff,aif,aifc,cdda"
"audio/x-aiff"="aiff,aif,aifc,cdda"
"audio/basic"="au,snd,ulw"
"audio/mid"="mid,midi,smf,kar"
"audio/x-midi"="mid,midi,smf,kar"
"audio/midi"="mid,midi,smf,kar"
"audio/vnd.qcelp"="qcp"
"audio/AMR"="AMR"
"audio/x-gsm"="gsm"
"video/x-mpeg"="mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa"
"video/mpeg"="mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa"
"audio/mpeg"="mpeg,mpg,m1s,m1a,mp2,mpm,mpa"
"audio/x-mpeg"="mpeg,mpg,m1s,m1a,mp2,mpm,mpa"
"video/3gpp"="3gp,3gpp"
"audio/3gpp"="3gp,3gpp"
"video/3gpp2"="3g2,3gp2"
"audio/3gpp2"="3g2,3gp2"
"video/mp4"="mp4,mpg4"
"audio/mp4"="mp4,mpg4"
"audio/x-m4a"="m4a"
"audio/x-m4p"="m4p"
"audio/x-m4b"="m4b"
"video/x-m4v"="m4v"
"video/sd-video"="sdv"
"application/x-mpeg"="amc"
"image/pict"="pict,pic,pct"
"image/x-pict"="pict,pic,pct"
"image/png"="png"
"image/x-png"="png"
"image/x-sgi"="sgi,rgb"
"image/x-targa"="targa,tga"

[HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\ActiveX\Installed MIME Types\]
"image/tiff"=-
"image/x-tiff"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\Installed MIME Types]
"image/tiff"=-
"image/x-tiff"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\Registry Backup\Media]
"image/tiff"=-
"image/x-tiff"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MIME\Database\Content Type\image/tiff]
"CLSID"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MIME\Database\Content Type\image/x-tiff]
"CLSID"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\EmbedExtnToClsidMappings\.tif]
@=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\EmbedExtnToClsidMappings\.tiff]
@=-

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Plugins\Extension\.tif]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Plugins\Extension\.tif]

------------------------------------------
Answered 02/16/2005 by: mccabr
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity