Hello Everyone.
I have some WinInstall NAI packages that I have to convert MSI.
1 problem I have is that the NAI packages call a couple of batch files that run before and after the installation.
When I use AdminStudio 6 to repackage the MSI it is ignores the batch file commands.
I heard that I can use 'Custom Actions' to run the batch files, but i haven't been able to figure out how. When I use the Custom Action Wizard I see options for running an EXE, VB or J Script, but nothing for .CMD files.
If anyone can help me out with this I would really appreciate it.

0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


welcome to my world !!! have done this using wise.. under MSI Script on the Action menu.. you can call functions.. Let me know... ok good luck
Answered 05/26/2006 by: aa006
Senior Purple Belt

Please log in to comment
I'm using InstallShield AS 6, but I'll try to get my hands on a copy of WISE and try your suggestion.
Thanks for trying to help aa006.
Answered 05/26/2006 by: winsysadmin
Yellow Belt

Please log in to comment
You use EXE.. then call cmd.exe /c "batchfile"
Answered 05/29/2006 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
I have done this too, i used a custom action to call the batch file and it worked fine.
Answered 05/30/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity