My K1000 is currently running Agent Package v.6.2.1025. Whenever a new package is available, I upgrade the agents through the appliance and I update my GPO's with an updated MSI. We are unable to manually install the 6.2.1025 .msi and we receive an error message saying that the KACE Agent .msi for 6.0.1079 is missing. I no longer have access to the 6.0.1079 msi file. It appears that the 6.2.1025 cannot be installed unless 6.0.1079 is uninstalled and 6.0.1079 cannot be uninstalled without the .msi file. Any input would be appreciated.
Answer Summary:
1 Comment   [ + ] Show Comment


  • how about forcing the uninstallation directly?
    c:\program files(x86)\dell\kace\amptools.exe -uninstall

    This uninstalls the agent on the client an can be run via GPO or the KACE.
    • Thanks for the reply, Nico. The affected computers do not have anything in their Dell\Kace directory. I'm not sure what happened to cause that. I even ran an msiexec /x {kace GUID} but the system still prompted for the original 6.0.1079 msi file. Any other ideas?
Please log in to comment

Community Chosen Answer


I uploaded the files for 6.0.1079. I only have the windows files archived. Hope this helps.
Answered 12/29/2014 by: h2opolo25
Red Belt

    • Thank you, but I've already located this link and downloaded the .kbin file. I do not want to upload the client bundle to my K1000 as I am already running a newer bundle version on it. Any ideas on how I can extract just the MSI from the .kbin file?
      • Unfortunately, deleting what you currently have and uploading this kbin would be the only way to get it from KACE at the moment. Once you have it, delete those files and re-upload the newer agent.
  • h2opolo25, I am unable to download the file due to it being hosted on
    • Ronny, if this is an issue with your organization blocking the website then download it from home. Alternatively if you suggest another file hosting site you prefer I can upload it there.
Please log in to comment


I ended up disabling the "Update Agent Settings" which eliminated my concern of installing an older agent over a newer one on our client machines. I then uploaded the 6.0.1079 .kbin file, got the msi I needed, then advertised the 6.2.1025 bundle. Thank you all for your help.
Answered 12/30/2014 by: Ronny
Senior White Belt

Please log in to comment
Answer this question or Comment on this question for clarity