Hi all,

I am fairly new to the K1000. My university recently started using it.

I have the kbox agent installed on all of my department computers and can see them all just fine.
None of the domain users have administrative rights.

I need to install updates to Java RE and Flash player.
I tried to creat a managed install for Java 6 update 31 and it is prompting the users for administrative rights before it can install. I really want to be able to silently install these updates.

I tried creating an online kscript, selected "Run As User" and put in an account with domain admin rights.

I added the java install file as a dependency, then under Task 1, I did:

Verify 1. Launch a program... For the directory, I put "$(KACE_DEPENDENCY_DIR)" For File, I put the file I uploaded in the dependency area (jre-6u31-windows-i586.exe).

I hit "Run Now" and it says it succeeded, however when I go to the log I get:
Output Log

Running As : netadmin
Unable to launch program (because file does not exist): C:\Program Files\KACE\KBOX\\packages\kbots\43\jre-6u31-windows-i586.exe False?
Error creating process: C:\Program Files\KACE\KBOX\\packages\kbots\43\jre-6u31-windows-i586.exe , System Error Code: 267 System.ComponentModel.Win32Exception: The directory name is invalid

Activity Log

Launching program: C:\Program Files\KACE\KBOX\\packages\kbots\43\jre-6u31-windows-i586.exe



Any ideas? please help!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Welcome to the KBOX.

The kbox agent runs as local system, so it should have the rights you need.

How did you setup your managed install? Typically I'll put all of my install commands in a setup.bat file. If you run your installer outside the KBOX does it install correctly?

Casey
Answered 02/23/2012 by: cmccracken
Orange Senior Belt

Please log in to comment
0
I'm an idiot.. I must not have hit save when I uploaded the dependency. I just re-added thedependency and hit "Save" and now it works!!!
Answered 02/23/2012 by: korimus
Yellow Belt

Please log in to comment
0
OK new issue. using the script only installs on machines that are connected to the kbox when I hit "Run Now." So now i have about 40 machines that didn't get the install.. Is there another way to do this where it installs when the computer turns on?
Answered 02/23/2012 by: korimus
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity