I am trying to setup a machine to be a replication share for our K1000. The machine has the latest 5.4 kace agent installed, is in the KACE org which I am creating the replication share for, and I have created a folder to hold everything on the local machine. I have shared the folder with the local admins group having full rights, the Everyone group with Read only rights, and a Active Directory group with full rights. I believe I have everything setup correctly but nothing seems to sync. Do you have to open any ports other than the default ones to use the k1000 for this to work? I am using my domain account for the Destination & Download user and I have also tried the local account. The below image is how I currently have it setup. Thanks in advance!

Answer Summary:
apparently it doesn't start syncing right away when you tell it to start replication on selected items. I just didn't wait long enough as it replicated over night. Thanks again everyone!
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


Your download path should be in UNC format. Based on the name in the image it should be \\IS-KACETEST\Replication (assuming replication is the share name) and it should work.

Answered 02/05/2013 by: Timi
Seventh Degree Black Belt

Please log in to comment



The destination path can use local drive syntax but the download path always needs to be formatted with UNC parameters.

Answered 02/06/2013 by: mpace
Red Belt

  • When i came in this morning it had replicated. So it must have done it on its own schedule and not when I told it to manually that afternoon. Sorry for the false alarm and thanks for the replies.
  • I do have one quick question. How do the managed installs work for machines checking into the replication share if the MI's are setup to use the alternate download location? Do the machines still pull the software from the alt. download location or does that sync to the replication share and then it is pulled from there? Thanks!
  • You should not have a label with an alternate download location and a replication share label assigned to a machine :) It will not know where to grab the data and if I remember correctly, it will fail. Could be tested just with a separate client machine and separate label.
  • This also applies to the MI alternate location settings.
  • Am I correct in that I created a Machine Smart Label that is assigned to all of the machines in that KACE org and then assigned that label to the RSA? We have over 30 orgs setup in KACE since we have a very silo'd IT organization. If a org in KACE wants an RSA it will most likely server every machine in their inventory. Is there a better way I should setup the label(s)?

    I looked on the RSA and it looks like it downloaded the "dummy" files associated with the software inventory records for the MI's that are using the alt. download location. So, does that mean that in order for MI's to work with RSA's you can only upload the actual software package directly to KACE and not use the alt. download location?

  • The machine label that you create is the label that you choose in the create/edit repl share page view. This label is assigned to all machines that should be served by this repl share you have just configured.

    When you say RSA I believe you mean the replication share, I think of the K2000 when I read RSA ;) The files that you see on the replication share are either named as filename.MD5hash or filename.MD5hash.part iirc.

    Only packages (MIs) in the K1000 / uploaded to the MI or SW Inventory item are replicated. The packages that are AT the alt location, are not replicated. If you have a lot of Microsoft in place you may use DFSN and/or DFSR? This could help perhaps with the decision in terms of the labels. Otherwise I believe you would have a repl share agent / one label per ORG that you host on the kbox.

    Hope it helps.
    • Yes it does. Thanks! Sorry about the RSA slip-up use. Doing too many things at one. lol
Please log in to comment
Answer this question or Comment on this question for clarity