Help with MSI (Microsoft Installer) error 2765: Assembly name missing from AssemblyName table : Component: [4].
2 Comments   [ + ] Show Comments


  • Another butt-saving on your part. Thank you.
  • have same error but cant fix with this method. Internal Error 2765. File317.

    any suggestions?
    • Find the file in the WiseSourcePath table and change the attribute to 16. Then find the file in the MsiAssembly table and delete the row. That is an alternate way to do the same thing. It works
Please log in to comment

Community Chosen Answer

Cause The attributes in the WiseSourcePath table indicate that the [problem] files are .NET assemblies. Resolution Summary 1. Go to the Setup Editor > Tables > WiseSourcePath table 2. The Attributes column for the [problem] files should currently be 8. Change the attributes column for these three entries to 16 3. Go to the Files page 4. Double-click on each of the [problem] files, go to the Assembly tab and change the Assembly Type to None. 5. Compile the installation. This time when you compile, the Assembly Type should remain None even if the Rescan Com interop registry keys on compile option is selected
Answered 10/24/2007 by: Chiun
Yellow Belt

  • Excellent post. Exactly right. Thank you!!! You saved me a LOT of time chasing that one.
  • Very useful. Thanks
  • Thank you. This helped me.
  • Sweet! Time saver!
Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.



I have found a faster way.

Delete the whole table WiseSourcePath, or at least the files with attribute 8.

Then delete the whole table MSIassembly, you don't have to change the files themselves.

Answered 04/15/2016 by: Basvv85
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity