Good morning fellas, I was given the task to deploy SAS Add-in 6.1 to 500 computers. Since I was given and exe file I did a distribution install. First I did capture file called and created a script to copy to C:\ before distribution install would start. After many tries found out did not install. I manually launch the installation from the installation folder and found out it was failing on task 5 SAS/GRAPH ActiveX Control, after some research found out how to fix it. I created a script to check for that file and if exist rename so installation would continue. Deployed again using distribution and did not install. I created script to install it from where the installation file is located c:\programdata\dell\kace\downloads\115782\sas.exe /verysilent -- -responsefile "c:\" and did not install. At this point I’m frustrated because I also found out KACE does not take special characters such - -- so I tried another distribution and script with the following command c:\programdata\dell\kace\downloads\115782\sas.exe /verysilent "--" "-responsefile" "c:\". I run the script from the kbots folder it does not install SAS properly, I can see the installation folder on the program files folder but when I launch SAS switcher utility it does not show anything but I can see it on the add remove programs. At the moment I tried different script methods such run a batch file, launch a program options from scripts. The weird thing is when I make a script to copy a batch file from my computer to copy the batch file to remote computer to the C:\ and run it from there SAS installs fine. If anyone has installed SAS using KACE please let me know what you did or what to do, thanks in advance.

0 Comments   [ + ] Show Comments


Please log in to comment



Here is my own answer

Answered 05/23/2014 by: josefino
Senior Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja