Currently, I am installing Google SketchUp v8 using this path, which was mentioned from Google SketchUp v7 info:

GoogleSketchUp8.msi LicenseAccepted=1 INSTALLGOOGLETOOLBAR=0 SETDEFAULTSEARCH=0 /qn /norestart

This has worked. Now I need to find a way to disable the update. According to Google SketchUp v7 info, it states:

HKCU\Software\Google\Preferences\CheckForUpdates=0
HKCU\Software\Google\Preferences\UpdateDefaultOn=0

But v8 does not use it... it's inside the

HKEY_USERS\<UNIQUE ID OF USER>\Software\Google\SketchUp8

Has anyone found a way to disable the update during installation?

Thanks,
1 Comment   [ + ] Show Comment

Comments

  • Hi tsutton, I am currently working on this piece of software, so hopefully i can lend a hand! There is a way of stopping auto-updates, well it worked for me! Open the MST up in Installshield... and put in the following path: HKCU\Software\Google\SketchUp8\Preferences Add the following key: DWORD "CheckForUpdates" 0x0000000. I would also recommend creating a new component called "Prefs" or something like that, and linking it to that, as there will be a lot of registry work to do with this application (If you dont know already!), so it will be useful to link all the registry modifications in HKCU together under one component! Hope this helps! :) Mikerosoft
Please log in to comment

Answers

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
0
This looks like a job for ActiveSetup or msi self-healing. Add the keys to the MSI (HKEY_CURRENT_USER) and either make an advertised shortcut or add the necessary ActiveSetup keys.

PJ
Answered 02/01/2011 by: pjgeutjens
Red Belt

Please log in to comment
0
HKEY_USERS\<UNIQUE ID OF USER> mirrors users configuration in HKCU, its better to look for the values in HKCU\Software\Google\SketchUp8
Answered 02/10/2011 by: jB!
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity