When you install google desktop search using silent install switches it creates a desktop shortcut. I have noticed that if you delete this shortcut using a script it comes back once google desktop is launched after a restart. Did anybody else overcome this problem. Is there a way to disable the install of this shortcut. Please let me know if you have any ideas. I am using the original msi file (GoogleDesktopSetup.msi) for version 5.1.707.23222.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
The shortcut returns because the app is self-healing.

Create a transform for the MSI and delete the shortcut from the transform: the quickest way is to delete the relevant row from the Shortcut table. At install time, make sure you use the relevant command line or option (depending on how you deploy your MSIs) to include the transform.
Answered 11/12/2007 by: VBScab
Red Belt

Please log in to comment
0
Eventhough this app has an extension of MSI it is not a proprietary MSI. All it does is launch a set of CA's which will perform the installation/uninstallation. There are no rows in shortcut table and that is why I have used a script to delete the shortcut instead of deleting it from the MSI. This app is not self healing at launch. I think when the application launches at startup it creates a default user profile which has the desktop shortcut as one of its setting.
Answered 11/12/2007 by: marlboro
Yellow Belt

Please log in to comment
0
There's probably a property that can be set to enable/disable the s/c creation. Have you tried Google support?
Answered 11/12/2007 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity