Hello,

 

We have an ongoing issue on our network with our Windows 7 systems where some computers have IE9 32 bit set as the default, and some have IE9 64 bit set as the default web browser. On systems where IE9 64 bit is set as the default we get a lot of problems with various intranet sites that are running add-ons for 32 bit browsers. (No 64 bit addons are available from the vendors) We want to force 32 bit to be the default always, but have not found a clean way to do this.

I found this script, http://csi-windows.com/toolkit/csiresetie32-bitshortcuts , which is similar to something we developed as a work-around, but it is a dirty way of doing it as it creates a static IE icon in the taskbar and when it opens, it launches a second IE icon in the taskbar.  If a user launches an Internet shortcut that they have on their system, or a file share, it will still open in IE 64 bit because 32 bit is not the default, only the icon in the task bar is.

We have 1500-2000 Windows 7 systems and it seems to be intermittant on which ones get effected. Most are effected right after "imaging" (not a static ghost image), but some are fine for a while then seem to switch as some point. (Unknown if the user did it, or not)

We deploy our systems using SCCM 2007 and the WIM has IE8 installed and we upgrade to IE9 apart of the deployment with the installation of our other standard software. We did find a source that stated that they had the exact same problem and they slipstreamed IE9 into the WIM and the problem went away. We could do that, although it is a lot of work and doesn't help us with existing systems in the field. Does anyone know of a way to force IE32 bit as the default via script or group policy?  Or how about restricting IE 64 bit so it can't be used?

 

Thank you,

Answer Summary:
Cancel
1 Comment   [ + ] Show Comment

Comments

  • I've had some success editing the following registry keys to use the x86 IE application:
    HKEY_CLASSES_ROOT\IE.FTP\shell\open\command
    HKEY_CLASSES_ROOT\IE.HTTP\shell\open\command
    HKEY_CLASSES_ROOT\IE.HTTPS\shell\open\command

    As well as creating a script to swap out the Internet Explorer.lnk shortcut with one pointing to the X86 version in all existing user profiles.
    C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\Internet Explorer.lnk

    Going to try it on a computer with the IE64 bit issue with various types of links and see how it works out. (Using a desktop shortcut pointing to a URL, using a weblink within an email or word document and clicking on the IE icon in the task bar and going to a website with 32 bit add-ons.

    Thanks
Please log in to comment

Community Chosen Answer

1

I think I have answered my own question. I managed to fix a "broken" system by editing the following registry keys to point to the x86 location of IE:

HKEY_CLASSES_ROOT\IE.FTP\shell\open\command HKEY_CLASSES_ROOT\IE.HTTP\shell\open\command HKEY_CLASSES_ROOT\IE.HTTPS\shell\open\command

As well as creating a script to swap out the Internet Explorer.lnk shortcut with one pointing to the X86 version in all existing user profiles. C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\Internet Explorer.lnk

 

Thanks

Answered 01/23/2014 by: RichE1982
White Belt

Please log in to comment

Answers

0

Have you thought about using a software restriction policy to block IE x64? That would stop the use of x64 IE, but will most likely cause a jump in calls as ppl x64 shortcuts will stop working.

You could use GPO to remove the IE x64 shortcut as well, so ppl in future wont be able to use it.

About all I can think of at the moment.

Answered 01/22/2014 by: rileyz
Red Belt

  • Thank you for the reply. I've looked into ways I could utilize group policy to fix this, but as you said restricting IE64 would result in calls from everyone effected instead of just the people with IE64 using websites with 32 bit add-ons.

    And it is not that users are using the Internet Explorer (64-bit) shortcut, it is that their existing Internet Explorer icon in the task bar is pointing to the 64 bit IE application.
    • All the best with your issue, sounds like one of those issues that will make your head explode (:
Please log in to comment
0

not entirely sure if this will work, and I have no access to an x64 machine at the moment, but there's a tool C:\windows\system32\ie4uinit.exe which allows you to 'reinstall' IE settings

Try running the 32-bit version of this file (with admin credentials) with this parameter:

ie4uinit.exe -reinstall

Answered 01/23/2014 by: pjgeutjens
Red Belt

  • Thank you. I am setting up a computer right now to test this.

    I can replicate the issue if I log into the computer with a non-administrator account right after "imaging" is complete. If I log in using my admin account as soon as imaging completes, it works fine and the Internet Explorer icon is set to use IE 32 bit. (For me anyway, I've heard of techs having the issue after logging in as themselves).
Please log in to comment
Answer this question or Comment on this question for clarity

Share