We have out K1000 exposed globally and it is awesome to be able to deploy software and manage users at home.  We are now going to start to force user to use the portal instead of emailing in so we customized the welcome page to have some links to some online docs where they can see how to use the portal.  We are hitting a major stumbling block because of how the K1000 masks it url when you are not using https://kbox/userui or https://kbox/adminui.

What we are seeing is really an annoying IE and Chrome issue where the prompt are either non-existent or in the little yellow bar that is easy to ignore and annoying.  Since we are using SSL for the Kbox because we have it exposed user cannot get to an instruction document on the non-ssl sites interally or externally unless they go to https://kbox.myco.com/userui.  Without the userui at the link on the page is considered mixed mode.

We already have our Intranet zone on low and we would still have to make an adjustment.  I don't want to have my users have to do this:

http://www.withsteps.com/694/how-to-remove-only-secure-content-is-displayed-ie9-message.html

Is there a way so I can configur the Kbox to go to https://kbox.myco.com/userui even when they do not specify?

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
 
 

 
Answered 02/01/2014 by: hmoore
Second Degree Blue Belt

  • That is just to enable or disable SSL. I want SSL for sure since this is exposed outside the company.

    The issu is when someone goes to https://kbox.myco.com (or http:// and gets redirected) they are in some sort of a wrapper where if they click a hyperlink to say http://someserver.myco.com they get a warning that the content is not secure and will not be displayed or they don't get anything at all.

    Now if I go to https://kbox.myco.com/userui user are not in some sort of wrapper, then the links behave like they would on other sites. For some reason that masking of the URL that K1000 does causes security issues.

    I would to turn off that wrapper.
Please log in to comment
Answer this question or Comment on this question for clarity