Is there a way to configure the K1000 agent (5.5) to force a check in at every boot?  I have a smart label that checks the current subnet for the computer to establish a Site - XXXXX label.  I have several packages in the K1000 Software Library that I limit by site .  The issue I am seeing is when a user comes back to the office from home or a trip the Site - XXXXX label is not updated unti the next checkin so if the user goes to the Software Library they do not see the correct selections available to them.

Thanks

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
Run a Force check-in script which is available in the Scripting>>Scripts 

Scheduling:

Don't Run on a Schedule
Run Every  
Run Every  at  :
Run on the  of  at  :
Custom Schedule: 
Also Run Once at next Client Checkin
Also Run at Machine Boot Up
Also Run at User Login
Allow Run While Disconnected (This option must be enabled due to the script running at boot or login.)
Allow Run While Logged Off (This option must be enabled due to the script running at boot or login.)


Check the check boxes 

Also Run at Machine Boot Up
Also Run at User Login
Answered 07/16/2014 by: anand.30hiremath
Blue Belt

Please log in to comment
0
I see two options:
There is a script that forces a check-in. You could schedule that script to run on a schedule and check the box to also run at boot-up.

You could add the command to run the script to the startup programs on the machine. The command is:
C:\Program Files\Dell\Kace\runkbot.exe 4 0
for a 32-bit machine

I would probably use the second method even though it involves making changes to the local machine. I haven't had consistent results using the scripting engine to run scripts at every boot.
Answered 07/10/2014 by: chucksteel
Red Belt

  • I think I will start with the schedule/bootup and then maybe a GPO to add it to the machine startup script
Please log in to comment
Answer this question or Comment on this question for clarity