I have doubts about the new Flash Player 10.3 and automatic updates.

We distribute Flash Player with SCCM, and I use a mms.cfg to disable updates. But this new version 10.3 comes with a control panel applet (FlashPlayerCPLApp.cpl) where users can configure automatic updates as well.

Adobe states the mms.cfg file overrides the user settings, but are we sure about this? (is this article up-to-date?)

Note: Settings in mms.cfg override the users settings and users cannot change it through Settings Manager. Settings Manager, as viewed by the user, doesn't reflect configuration settings set by mms.cfg

Can someone confirm that the mms.cfg file takes precedent over the control panel applet?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I had some doubts as well but I have confirmed that mms.cfg overwrites any user-select settings in the settings.sol file that is under "C:\Users\[username]\AppData\Roaming\Macromedia\Flash Player\macromedia.com\support\flashplayer\sys".

I confirmed this by following this Adobe KB article and using Wireshare network/packet sniffer. When 'AutoUpdateDisable=1' is in mms.cfg and a flash page is loaded flash does not check the Flash update server for updates.
Answered 05/19/2011 by: trafsta
Yellow Belt

Please log in to comment
0
Recently, I was prompted for an update even though I had AutoUpdateDisable = 1 in the mms.cfg file.

In the documentation from Adobe I downloaded, it looks like there is a space before and after the "=", here you guys don't have spaces and the link posted shows no spaces. Is that my mistake or does it not make a difference?
I made the change and didn't get prompted. I don't have access to a network sniffer and can't confirm this is correct, but if it is a fix, I'd like to deploy it to my domain.
Thanks,
Answered 06/16/2011 by: abe_froman
Yellow Belt

  • I can confirm the spacing is required and the correct way to disable automatic updates for both Flash Player 10.3 and 11.1.
Please log in to comment
0
The mms.cfg setting worked for me in Windows XP when I sniff with wireshark.
But it does NOT work for me in Windows 7, with the path suggested by Adobe. I´m on vacation now for 4 weeks so I´ll investigate this further when I get back. In the meantime we have a pretty old flashplayer in my company.
Answered 06/23/2011 by: Agathorn
Senior Purple Belt

Please log in to comment
0
I just tried it again and no luck. It doesn´t work in WIndows XP either, the first time I go to a flashpage I can sniff packages with wireshark to fpdownload2 at macromedia.com. I have noticed though that it seems to work the second time and on. But that doesn´t help I guess when flash already has updated itself after the first try.

Has anyone a solution how to disable autoupdate completely?
Answered 08/03/2011 by: Agathorn
Senior Purple Belt

Please log in to comment
0
I was working on this. If the MMS files are set (and, as abe_froman mentioned, with spaces, so "AutoUpdateDisable = 1") the update option in the Flash control panel is disabled *and* grayed out. I haven't run a packet sniffer, but all I care about is that users don't see a notification, so good enough for me.
Answered 08/11/2011 by: cshbell
Senior Yellow Belt

Please log in to comment
0
Humm, now when I try the settings in control panel - Flash - is set to auto update and not greyed out. I have tried without spaces and with spaces, no difference. The file is saved under C:\Windows\System32\Macromed\Flash\mms.cfg and I now have AutoUpdateDisable=1 set (also tried AutoUpdateDisable = 1)

What am I doing wrong here???
Answered 08/12/2011 by: Agathorn
Senior Purple Belt

Please log in to comment
0
I wrote the mms.cfg file to both %WINDIR%\System32\Macromed\Flash and %WINDIR%\SysWOW64\Macromed\Flash. Don’t know if that made a difference or not. I’ll be clean-imaging a new system next week and will revisit this to see if I can spot any patterns.
Answered 08/13/2011 by: cshbell
Senior Yellow Belt

Please log in to comment
0
Even if I dont put the configuration in the mms.cfg the player don´t update itself automatically when I visit a flash-page. I guess it´s because the player is rather new (although not the newest one available). So it´s hard to know if it´s working or not.
Answered 08/14/2011 by: Agathorn
Senior Purple Belt

Please log in to comment
0
So after running a clean install, putting the mms.cfg in both System32 and SysWOW64, the Updates section of the Flash control panel is indeed grayed out, but updates are enabled. Boo. So this is not fixed yet.
Answered 08/26/2011 by: cshbell
Senior Yellow Belt

Please log in to comment
0
Please note, that there is an issue with using the mms.cfg (AutoUpdateDisable=1) method to disable automatic update notifications and what's seen in the Flash applet and the web-based Settings Manager. It works as expected but doesn't display the correct result which would be to disable/grey out the update selections.

A bug report has been submitted to Adobe and it's found at the following URL:

https://bugbase.adobe.com/index.cfm?event=bug&id=2919136
Answered 09/12/2011 by: spirosl
Senior Yellow Belt

Please log in to comment
0
We've been deploying the mms.cfg file for a while now and it's never worked. Every freaking time Flash does an update, we have users complaining about constantly being prompted.

Maybe I'll have to try adding the spaces and give it another shot.
Answered 09/29/2011 by: blennon
Yellow Belt

Please log in to comment
0
Yeah it actually seems to be working. I haven´t received any prompts for updates yet anyway.
Answered 10/09/2011 by: Agathorn
Senior Purple Belt

Please log in to comment
0
I agree, haven't got any update notifications either.
Answered 10/10/2011 by: bennebiest
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity