Hi,

I have spent several hours with IEAK 7 most setting works fine, but when I want to tweak so the meny bar show up then it get harder.

I understand that INSTALL.INS is an unattended file and I found some interestion sections in the file..
[ExtRegInf]
inetset=*,inetset.inf,DefaultInstall
[ExtRegInf.Hkcu]
inetset=inetset.inf,IEAKInstall.HKCU

So in the inetset.inf i put, my reg tweak, it work fine if I right click the inf and take install all reg key get installed, but if I run the INS\WIN32\SV\IE7Setup.exe then my tweak dont get installed but the rest seams to work.
I also saw that if I installed the orginal IEAK package everything whent fine, but if I then deleted some registry keys and reruned the IE setup the registry keys dont show up.

It seems so easy to fix an corp IE package, it was harder than i thought...

/SaiTech

[Version]
Signature=$CHICAGO$
SetupClass=Base
[DefaultInstall]
AddReg=AddRegSection.HKLM,AddRegSection.HKCU
RequiredEngine=Setupapi,"missing setupapi.dll"
[DefaultInstall.HKLM]
AddReg=AddRegSection.HKLM
RequiredEngine=Setupapi,"missing setupapi.dll"
[IEAKInstall.HKLM]
AddReg=AddRegSection.HKLM
RequiredEngine=Setupapi,"missing setupapi.dll"
[DefaultInstall.HKCU]
AddReg=AddRegSection.HKCU
RequiredEngine=Setupapi,"missing setupapi.dll"
[IEAKInstall.HKCU]
AddReg=AddRegSection.HKCU
RequiredEngine=Setupapi,"missing setupapi.dll"
[AddRegSection.HKLM]
[AddRegSection.HKCU]
HKLM,"SOFTWARE\Microsoft\Internet Explorer\Main","AlwaysShowMenus",0x10001,1,0,0,0
HKLM,"SOFTWARE\Microsoft\Internet Explorer\Toolbar\WebBrowser","ITBar7Position",0x10001,1,0,0.0
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

There are no answers at this time
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

Answer this question or Comment on this question for clarity