I'm trying to deploy Firefox 18.0.1 and as always the usual command -ms works great, but what doesn't work anymore, is configuring of the browser, so the users get similar configuration.

I have this file local-settings.js in C:\Program Files\Mozilla Firefox\defaults\pref

pref(“general.config.obscure_value”, 0);
pref(“general.config.filename”, “mozilla.cfg”);

This file tells Firefox where to get it configuration from, in this case mozilla.cfg

So I have mozilla.cfg in C:\Program Files\Mozilla Firefox, which contains:

//Firefox Default Settings

pref(“browser.startup.homepage_override.mstone”, “ignore”);

//disable default browser check
pref(“browser.shell.checkDefaultBrowser”, false);

// Disables ‘Know your rights’ message on first launch
pref(“browser.rights.3.shown”, "true");

But it doesn't work, it should work, as it's the "official" way to use custom config in Firefox, but my cfg file is simply ignored and I have no idea why.

I also have override.ini in C:\Program Files\Mozilla Firefox, so it doesn't run import settings guide


Any ideas and own expirence with Firefox 18 and these config files would be great, thank guys.

0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


Found this info, not sure if it helps.. 
mozilla.cfg has to be placed in the Firefox installation directory, and local-settings.js inside installation directory\defaults\pref. 

Answered 01/23/2013 by: jaybee96
Red Belt

  • Thanks, That is also what I'm doing, but doesn't seem to work. Might be a bug in Firefox, I would just like it to be confirmed from other who deploys Firefox :)
Please log in to comment



The right place to put your local-settings.js has changed: see http://mike.kaply.com/2012/08/01/major-change-setting-default-preferences-for-firefox-14/

Answered 07/10/2013 by: flabdablet
White Belt

Please log in to comment

override.ini has to be set in INSTALLATION DIRECTORY\browser\ since Version 21 or so

Answered 10/11/2013 by: EbrithilBowser
Fourth Degree Green Belt

Please log in to comment

First force the users to use the same profile path which is defined in %APPDATA%\Mozilla\Firefox\profiles.ini  :



Then copy a default user.js file to the folder %APPDATA%\Mozilla\Firefox\Profiles\firefox.default  with e.g. the following content:

# Mozilla User Preferences

/* Do not edit this file.
 * If you make changes to this file while the application is running,
 * the changes will be overwritten when the application exits.
 * To make a manual change to preferences, you can visit the URL about:config

user_pref("app.update.enabled", false);
user_pref("app.update.service.enabled", false);
user_pref("browser.search.update", false);
user_pref("browser.shell.checkDefaultBrowser", false);




Answered 02/04/2013 by: Rvlieburg
Third Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity