Can anyone tell me what actually triggers a failed install when pushing out a Managed Install?

I have various installs that work perfectly and install the chosen software correctly, however they pop up as failed.

It's not on every install I push out but quite a large amount.

Any ideas on how I can fix this?

Thanks!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
A managed installation will "fail" if the software inventory item it is linked to is not detected on the system after the installation. For example, if you deploy MS Office 2007 and it isn't detected on the system after the installation runs, then it has "failed" according to the KBOX.
Answered 02/02/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
One thing I would note here, software that increments the title based on patching, messes this up too. Back to the trusty office 2007 install, When I did mine, I had inventoried office 2007 patched, which made it display a higher version, which would make my initial unpatched MI show as failed.
Answered 02/03/2010 by: lindsamw
Orange Senior Belt

Please log in to comment
0
If you want to avoid such situation than always manually install the software, for exemple MS Office 2007 on a test machine, and then upload the office installation zip file to the Microsoft Office 2007 sofware inventory item present under inventory/Software tab of Kbox admin interface.
Answered 02/04/2010 by: afzal
Fourth Degree Green Belt

Please log in to comment
0
The problem with that Afzal, Office 2007 then gets patched, and your MI will never show as having worked :) I have it working in my location, but only because I always push out the fully installed product.
Answered 02/04/2010 by: lindsamw
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity