While trying to self repair in non previleged user, the following error msg is displayed

"The feature you are trying to use is on a network resource that is unavailable"
Use Source: [Default installation path of the non previleged user]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Generate a verbose log for this and it will tell you exactly where the problem lies.
Answered 02/13/2008 by: India_Repackaging
Blue Belt

Please log in to comment
0
ORIGINAL: India_Repackaging
Generate a verbose log for this and it will tell you exactly where the problem lies.
Not strictly true, unless you're very lucky. It will provide a *clue* as to where the problem lies.

Also, you imply that the MSI could be re-run with the '/L*V' command-line argument. which it can't, since this is a repair. To generate a verbose log for repairs, you need to enable MSI logging. To do that, create a registry String value HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer\Logging and set the value to "voicewarmup" (without the speech marks). Log files prefixed with 'MSI' followed by 4-5 random alphanumeric characters and with a .LOG extension will get written to %SystemRoot%\TEMP. Be aware that this registry entry sets a machine-based policy and you will thus get a log for *all* MSI activity, including advertisements, so you may want to re-set the value when your package is successfully repairing.
Answered 02/14/2008 by: VBScab
Red Belt

Please log in to comment
0
I here send the log file( in non previleged user mode)

______________________________________________________________


=== Verbose logging started: 2/8/2008 2:26:07 Build type: SHIP UNICODE 3.01.4000.4042 Calling process: C:\WINDOWS\system32\rundll32.exe ===
MSI (c) (24:04) [02:26:07:832]: Resetting cached policy values
MSI (c) (24:04) [02:26:07:832]: Machine policy value 'Debug' is 0
MSI (c) (24:04) [02:26:07:832]: ******* RunEngine:
******* Product: {6599C3C3-1723-41A4-ABBC-C26F2D046B06}
******* Action:
******* CommandLine: **********
MSI (c) (24:04) [02:26:07:832]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (24:04) [02:26:07:832]: Grabbed execution mutex.
MSI (c) (24:04) [02:26:07:862]: Cloaking enabled.
MSI (c) (24:04) [02:26:07:862]: Attempting to enable all disabled priveleges before calling Install on Server
MSI (c) (24:04) [02:26:07:882]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (C4:94) [02:26:07:902]: Grabbed execution mutex.
MSI (s) (C4:3C) [02:26:07:902]: Resetting cached policy values
MSI (s) (C4:3C) [02:26:07:902]: Machine policy value 'Debug' is 0
MSI (s) (C4:3C) [02:26:07:902]: ******* RunEngine:
******* Product: {6599C3C3-1723-41A4-ABBC-C26F2D046B06}
******* Action:
******* CommandLine: **********
MSI (s) (C4:3C) [02:26:07:902]: Machine policy value 'DisableUserInstalls' is 0
MSI (s) (C4:3C) [02:26:07:902]: Setting cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:902]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:902]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:902]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:902]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:902]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Attempting to recache package via ProductCode. Beginning source resolution.
MSI (s) (C4:3C) [02:26:07:912]: User policy value 'SearchOrder' is 'nmu'
MSI (s) (C4:3C) [02:26:07:912]: User policy value 'DisableMedia' is 0
MSI (s) (C4:3C) [02:26:07:912]: Machine policy value 'AllowLockdownMedia' is 0
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Media enabled only if package is safe.
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Looking for sourcelist for product {6599C3C3-1723-41A4-ABBC-C26F2D046B06}
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Adding {6599C3C3-1723-41A4-ABBC-C26F2D046B06}; to potential sourcelist list (pcode;disk;relpath).
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Ignoring last used source.
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Now checking product {6599C3C3-1723-41A4-ABBC-C26F2D046B06}
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Machine policy value 'DisableMsi' is 1
MSI (s) (C4:3C) [02:26:07:912]: Machine policy value 'AlwaysInstallElevated' is 1
MSI (s) (C4:3C) [02:26:07:912]: User policy value 'AlwaysInstallElevated' is 0
MSI (s) (C4:3C) [02:26:07:912]: Using cached product context: machine assigned for product: 3C3C995632714A14BACB2CF6D240B660
MSI (s) (C4:3C) [02:26:07:912]: Product {6599C3C3-1723-41A4-ABBC-C26F2D046B06} is admin assigned: LocalSystem owns the publish key.
MSI (s) (C4:3C) [02:26:07:912]: Product {6599C3C3-1723-41A4-ABBC-C26F2D046B06} is managed.
MSI (s) (C4:3C) [02:26:07:912]: Running product '{6599C3C3-1723-41A4-ABBC-C26F2D046B06}' with elevated privileges: Product is assigned.
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Media is disabled for product.
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Processing net source list.
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Trying source C:\_Getronics\xxi\Shared\Install\Wise\Client\.
MSI (s) (C4:3C) [02:26:07:912]: Note: 1: 2203 2: C:\_Getronics\xxi\Shared\Install\Wise\Client\GlobalfsClientDev.msi 3: -2147287035
MSI (s) (C4:3C) [02:26:07:912]: Note: 1: 1706 2: -2147483646 3: GlobalfsClientDev.msi
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Media Disabled for this package.
MSI (s) (C4:3C) [02:26:07:912]: SOURCEMGMT: Processing URL source list.
MSI (s) (C4:3C) [02:26:07:912]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
MSI (s) (C4:3C) [02:26:07:912]: Note: 1: 1706 2: -2147483647 3: GlobalfsClientDev.msi
MSI (s) (C4:3C) [02:26:07:912]: Note: 1: 1706 2: 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:07:942]: User policy value 'SearchOrder' is 'nmu'
MSI (c) (24:C4) [02:26:07:942]: User policy value 'DisableMedia' is 0
MSI (c) (24:C4) [02:26:07:942]: Machine policy value 'AllowLockdownMedia' is 0
MSI (c) (24:C4) [02:26:07:942]: SOURCEMGMT: Media enabled only if package is safe.
MSI (c) (24:C4) [02:26:07:942]: SOURCEMGMT: Prompting user for a valid source.
MSI (c) (24:C4) [02:26:07:942]: Machine policy value 'DisableBrowse' is 0
MSI (c) (24:C4) [02:26:07:942]: Machine policy value 'AllowLockdownBrowse' is 0
MSI (c) (24:C4) [02:26:07:942]: Machine policy value 'DisableUserInstalls' is 0
MSI (c) (24:C4) [02:26:07:942]: Machine policy value 'DisableMsi' is 1
MSI (c) (24:C4) [02:26:07:942]: Machine policy value 'AlwaysInstallElevated' is 1
MSI (c) (24:C4) [02:26:07:942]: User policy value 'AlwaysInstallElevated' is 0
MSI (c) (24:C4) [02:26:07:942]: Product {6599C3C3-1723-41A4-ABBC-C26F2D046B06} is admin assigned: LocalSystem owns the publish key.
MSI (c) (24:C4) [02:26:07:942]: Product {6599C3C3-1723-41A4-ABBC-C26F2D046B06} is managed.
MSI (c) (24:C4) [02:26:07:942]: Running product '{6599C3C3-1723-41A4-ABBC-C26F2D046B06}' with elevated privileges: Product is assigned.
MSI (c) (24:C4) [02:26:07:942]: SOURCEMGMT: Browsing is disabled.
MSI (c) (24:C4) [02:26:07:982]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (24:C4) [02:26:07:982]: SOURCEMGMT: Now checking product {6599C3C3-1723-41A4-ABBC-C26F2D046B06}
MSI (c) (24:C4) [02:26:07:982]: Machine policy value 'AlwaysInstallElevated' is 1
MSI (c) (24:C4) [02:26:07:982]: User policy value 'AlwaysInstallElevated' is 0
MSI (c) (24:C4) [02:26:07:982]: Product {6599C3C3-1723-41A4-ABBC-C26F2D046B06} is admin assigned: LocalSystem owns the publish key.
MSI (c) (24:C4) [02:26:07:982]: Product {6599C3C3-1723-41A4-ABBC-C26F2D046B06} is managed.
MSI (c) (24:C4) [02:26:07:982]: Running product '{6599C3C3-1723-41A4-ABBC-C26F2D046B06}' with elevated privileges: Product is assigned.
MSI (c) (24:C4)MSI (s) (C4:3C) [02:26:48:329]: SOURCEMGMT: Failed to resolve source
MSI (s) (C4:3C) [02:26:48:329]: MainEngineThread is returning 1612
[02:26:07:982]: SOURCEMGMT: Media is disabled for product.
MSI (c) (24:C4) [02:26:07:982]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
MSI (c) (24:C4) [02:26:07:982]: Note: 1: 1706 2: 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:07:982]: SOURCEMGMT: Processing net source list.
MSI (c) (24:C4) [02:26:07:982]: Note: 1: 1706 2: -2147483647 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:07:982]: SOURCEMGMT: Media Disabled for this package.
MSI (c) (24:C4) [02:26:07:982]: SOURCEMGMT: Processing URL source list.
MSI (c) (24:C4) [02:26:07:982]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
MSI (c) (24:C4) [02:26:07:982]: Note: 1: 1706 2: -2147483647 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:07:982]: Note: 1: 1706 2: 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:23:376]: SOURCEMGMT: Trying source C:\_Getronics\xxi\Shared\Install\Wise\Client\.
MSI (c) (24:C4) [02:26:23:376]: Note: 1: 2203 2: C:\_Getronics\xxi\Shared\Install\Wise\Client\GlobalfsClientDev.msi 3: -2147287035
MSI (c) (24:C4) [02:26:23:376]: Note: 1: 1706 2: -2147483646 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:23:376]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (24:C4) [02:26:45:732]: SOURCEMGMT: Trying source C:\_Getronics\xxi\Shared\Install\Wise\Client\.
MSI (c) (24:C4) [02:26:45:732]: Note: 1: 2203 2: C:\_Getronics\xxi\Shared\Install\Wise\Client\GlobalfsClientDev.msi 3: -2147287035
MSI (c) (24:C4) [02:26:45:732]: Note: 1: 1706 2: -2147483646 3: GlobalfsClientDev.msi
MSI (c) (24:C4) [02:26:45:732]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (24:04) [02:26:48:339]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (24:04) [02:26:48:339]: MainEngineThread is returning 1612
=== Verbose logging stopped: 2/8/2008 2:26:48 ===
_____________________________________________________________
Answered 02/14/2008 by: sp_saratha
Yellow Belt

Please log in to comment
0
Hi Saratha,

Though I am not sure but I think the problem with your application is that Windows Installer is failing to resolve the SourceDir property and hence the source is not available during Repair.

I would suggest you check the ResolveSource action must always come after the CostInitialise Action and also check the value of SourceDir property that is resolved by Windows Installer.

Read about the ResolveSource and SourceDir properties from the .chm files.

I am also not sure why is the Windows Installer looking for the source in this particular location i.e .... C:\_Getronics\xxi\Shared\Install\Wise\Client\GlobalfsClientDev.msi - is this where you have your source located.

Cheers [:(]
Answered 02/14/2008 by: India_Repackaging
Blue Belt

Please log in to comment
0
ORIGINAL: sp_saratha
I here send the log file( in non previleged user mode)
Please don't! The majority of logs are "mostly air" (to paraphrase Microsoft's Shaun Orpen, describing MS Office file formats!) and posting them just clogs up the forum and makes posts hard to read. If a post is hard to read, potential responders might lose the will to respond. In future, please, just include the *relevant* section.
Answered 02/15/2008 by: VBScab
Red Belt

Please log in to comment
0
I don't think there is a problem resolving the source as it's taking from the metadata (registry).

From looking at the log I see some interesting log-entries:
Note: 1: 2203 2: C:\_Getronics\xxi\Shared\Install\Wise\Client\GlobalfsClientDev.msi 3: -2147287035
(Database: [2]. Cannot open database file. System error [3].)
Note: 1: 1706 2: -2147483646 3: GlobalfsClientDev.msi
(No valid source could be found for product [2].)

So first verify that the user has read permission on the original MSI and any external files.

Also I see the entry "SOURCEMGMT: Media Disabled for this package.".
Every log I've seen this a been Enabled instead of Disabled so first time I see this. There is also a line above stating "Machine policy value 'DisableMsi' is 1". This disables unmanaged applications so don't think that is the problem either.

Could you verify any windows installer policy set either locally or from a group policy (use rsop.msc locally on this machine).
Answered 02/15/2008 by: AngelD
Red Belt

Please log in to comment
0
ORIGINAL: India_Repackaging
Read about the ResolveSource and SourceDir properties from the .chm files.
Even more usefully, read http://blogs.msdn.com/heaths/archive/2007/10/25/resolvesource-requires-source.aspx

@sp_saratha, you might find the Windows Installer Log Analyzer a useful download. Also, although the log is verbose, I don't think you have all the options specified, as I can't see any of the built-in actions (e.g. ResolveSource!) being started. If using Group Policy, make sure you have 'voicewarmup' set for the 'Logging' value - http://www.pctools.com/guides/registry/detail/1127/
Answered 02/15/2008 by: VBScab
Red Belt

Please log in to comment
0
Is there any other option to enable self repair option for non-admin user other than providing the access rights for the MSI files ?

Have I to change any property in WSI package to enable self repair option for non-admin user?
Answered 02/17/2008 by: bhuvan
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: bhuvan

Is there any other option to enable self repair option for non-admin user other than providing the access rights for the MSI files ?

Have I to change any property in WSI package to enable self repair option for non-admin user?
Please don't hijack other posts. Answers to your post are, er, in your thread.
Answered 02/18/2008 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity