Hi,

I want to package Pro*c\c++. Vedor is Oracle. But while installing the source I am getting the below error.

The Java Run Time Environment was not found at
D:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\OraInstall2008-12-07AM\jre\vin\javaw.exe. Hence, the Oracle Universal Installer cannot be run.

Please visit the http://www.javasoft.com and install JRE version 1.3.1 or higher and try again.



But already I have JRE 1.6 in my build. I cleared the temp folder. But still it is showing the above error. Can any one give reply for this.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Off the top of my head....install 1.3.1?
Answered 12/05/2008 by: VBScab
Red Belt

Please log in to comment
0
That seems like a wild guess to me Ian!
Answered 12/05/2008 by: AngelD
Red Belt

Please log in to comment
0
It may seem that my initial response was sarcastic but many, many apps will only install if they detect a specific JRE version, even though they tell you that a higher one is acceptable.

generally, you can fool these apps by 'ghosting' the JRE registry entries. Take a look at your 1.6 entries in HKLM\Software\Javasoft\Java Runtime Environment. You'll see entries like this:

...............1.6
...............1.6.0_01

Export these to a .REG then edit that .REG so that the 1.6 becames 1.3 and the 1.6.0_01 becomes whatever the brain-dead Oracle installer wants (ProcMon will show you which keys it's trying to open). Note that you only need to edit the *keys*: leave the value data intact. Save the .REG then import it into your packaging machine's registry. You *should* find that the installer proceeds, happy that you do indeed have 1.3.1 installed (even though you don't, of course).

I have applied this principle to applications also, ghosting whatever the client's build version is into whatever the application wants and have yet to encounter an app which failed.
Answered 12/05/2008 by: VBScab
Red Belt

Please log in to comment
0
I have installed JRE 1.3.1, but still it is throwing the same error. Please suggest
Answered 12/05/2008 by: sanhivi
Second Degree Green Belt

Please log in to comment
0
(ProcMon will show you which keys it's trying to open).
Answered 12/05/2008 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity