When I try to install a patch to a game(Farcry) I get an error which says "transforms paths are not valid." Thats for the v1.3 patch. I installed the v1.1 patch with no problem. All my friends have the v1.3 patch installed problem-free so why does my comp. give me this error.

Here are my specs:
Pentium 4 3.0Ghz, 800mhz FSB, 1mB cache
1024 Corsair XMS DDR 400mhz Ram
Ati x800xt PE 256 GDDR3 Ram by Asus
Asus PS800D-E Motherboard
Maxtor HDD 120GB
I use Windows XP Pro, with SP2
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I suggest you remove the game from your computer then reinstall the game fresh and apply the patches.
Answered 03/07/2005 by: cdupuis
Third Degree Green Belt

Please log in to comment
0
I already tried that. I did a repair to windows to see if it would help, but it didnt. I also checked in the registry and erased a bunch of stuff related to farcry, but when I installed the game I could still install the v1.1 but not the v1.3 patch. It gives me the same error. "Transform paths not valid." It seems to create a .msi or .mst file (not sure which one) and its like it doesnt reckognize its there.
Answered 03/07/2005 by: MindGrasp
Yellow Belt

Please log in to comment
0
Do you have the required patches installed to accomodate this patch...some games require you to install all patches and do not allow the skipping of patches...

For patches the effects of the Version Relationship setting have changed - actually it now works as intended. If you have created a patch that targets multiple older versions, and have accepted InstallShield's default of "New version >= previous version" it is likely to fail! Users have reported error 2768: "Transform in patch package is invalid" when they tried to apply such a patch. It is highly recommended to use "New version = previous version" instead. The wording in the patch wizard is misleading, actually the meaning is "Existing version = base version", where base version is the version that the patch targets. Suppose you have a patch that should update version 1.0.1 of your product to version 1.0.2, then the base version would be 1.0.1. This patch should only be applied to a system where version 1.0.1 is currently installed, not on higher versions. This is all very confusing, as it had been documented incorrectly in earlier versions of the Windows Installer SDK, and also never worked as documented until MSI 2.0.

I know this above excerpt is confusing, but I gather it says what I said. You could also try installed MSI version 3.0
Answered 03/07/2005 by: cdupuis
Third Degree Green Belt

Please log in to comment
0
I understand what your saying but my friends installed from 1.0 to 1.3 without any problem. There is a new patch out, 1.31. But in that case you do need the 1.3 patch. Patch 1.2 was recalled so I dont have many more options. I have tried loading the patch from safe mode, and from the command prompt but I have had no success. I am currently trying to create the transforms paths from the command prompt but I am not too familiar with this so I am trying.
Answered 03/07/2005 by: MindGrasp
Yellow Belt

Please log in to comment
0
I solved the problem using a program called windows installer clean up. Apparently there was an error in the registry. You can get the programs from Microsoft's page, this is where I got it from: http://support.microsoft.com/default.aspx?scid=kb;en-us;290301
Answered 03/10/2005 by: MindGrasp
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity