Hi

I use Admin studio 8.0 and have created an msi. I have a virtual machine - XP SP2, that I use for testing. I have completed the testing of the msi package everything is working as expected. The package enables pdf functionality, adds a sybase datawindow PS printer for faxing, also Ghostscript is installed as part of the package to create the pdf for faxing. I've then wiped the virtual PC for a clean install and all works as expected, including sending a fax.

Problem is though, when I attempt to create an admin install by running msiexec /a "package name.msi" from a cmd prompt, I receive the message "Error 2203.Database: <msi location>Cannot open database file. System error -2147287008." This error appears right at the end of the process.

I've had a brief look for similar errors on this (excellent!) site. One solution was to check SYSTEM permissions, (which I've checked) and SYSTEM has full control of the folder where the msi and associated files live.

Am I making a basic error?

Thanks in advance for help.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Do you have any custom action that is accessing or opening the MSI in some way?
Try a verbose log during admin install and see if that gives you some more details on why it give you this error.
Answered 08/17/2007 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity