Howdy all, I am working on a package called SPECTRUM XXI version 4.2.
I have the package built in MSI format through installshield.
I am getting "error 1931 C:\Windows\system32\odbcconf.rsp Can't be updated thisfile is windows protected you may have to update the OS".
I have searched the site and Google groups for this error but nothing has turned up.
Anyone seen this error code before and find a reason for it?
We are using XP SP2.

ej
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
This is Windows File Protection - a new security feature for XP. Windows has a list of operating system files that are not eligible for replacement unless replaced by windows Update.

The first thing I would do is to be sure that this file does not exist as part of your operating system snapshot. If it does, don't include it in the MSI for XP. If you do manage to replace it, you will get a message that you need the original OS CD to replace it back and it will drive you nuts.
Answered 11/09/2005 by: madhatter
Senior Yellow Belt

Please log in to comment
0
Thanks MadHatter it worked.
Took a lot of re-work but I no longer get this error and the product installs.

ej
Answered 11/09/2005 by: erjones
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity