Hi Guys,
I have tested my MSI on a few different clean VMs and it works just find but after sending the package to QA team for further testing they get the following error when I push the package thru DS console "error 1321 Windows Installer has insufficient privileges to modify the file C:WINDOWS\system32\vsdata.dll and also another error comes if the user clicks on the first one "could not schedule file vsdatant.sys on reboot
I have updated the windows installer to version 3.1 but the issue still persists
Any suggestion (s)?
Thanks
Sam
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Do your VMs include one which has a vanilla build and for which you have an account with ordinary user's privileges? If not, it's time you did. You can then test deployment (by whatever mechanism you have), log on and application start-up for the targetted user. You would most likely have caught the error before the QA submission stage.

1321 means that the engine couldn't update a file with the level of privileges that the installing account has. http://itninja.com/question/help-with-msi-12594

What local privileges does the account used by QA have?
Answered 08/05/2009 by: VBScab
Red Belt

Please log in to comment
0
what do you mean by installing account? I push this package thru the DS console via the altiris agent of course
Answered 08/05/2009 by: Sam_jazz
Senior Yellow Belt

Please log in to comment
0
I know nothing about the Altiris deployment system but let's assume that the deployment pushes packages to an agent which installs using the local System account. Clearly that account *should* be able to do anything. However, it wouldn't be the first time that I've encountered systems which have screwed permissions - does anyone remember the very first release of Acrobat Pro v8 which set a folder's permissions such that all users and groups except 'Everyone' - including local 'Administrators' and 'System'- were removed from the ACL, and 'Everyone' was granted 'Read' access only? That was fun...

I suspect the folder/file in question has odd permissions. Have them try another box/build.
Answered 08/05/2009 by: VBScab
Red Belt

Please log in to comment
0
Honeslty, I don't think this is related to "user account" privileges
I have just deployed the same package to my work laptop on which I am "local Admin" and I got the same message "error 1321" on the other hand if I deploy it to a VM using the same user ID it installs just fine
I am thinking there must be an application that would interfere somehow with my MSI installation
Answered 08/05/2009 by: Sam_jazz
Senior Yellow Belt

Please log in to comment
0
My other suspicion was that it's trying to replace a file which is in use but you'd get a 1306 error. Worth checking, though...
Answered 08/06/2009 by: VBScab
Red Belt

Please log in to comment
0
Hi,
It turns out that the error was caused due to a built in firewall within the VPN client itself that uses the same files as some third party firewalls (e.g Zonelabs) which we use here at the office, therefore the solution has been corrected with later version of VPN clients according CISCO and they have added the following flag as a part of the installation package which will prevent the firewall to be installed if needed
msiexec.exe /i vpnclient_setup.msi DONTINSTALLFIREWALL=1
My question, Can I include the above command/switch to my current VPn package so it won't access files like vsdata.dll, vsinit.dll and vsdatant.sys ?
Do I need to create a CUSTOM ACTION to include the above command line?
SN
Answered 08/07/2009 by: Sam_jazz
Senior Yellow Belt

Please log in to comment
0
Do I need to create a CUSTOM ACTION to include the above command line?No. Either deploy using that command line or set that property in a transform and specify the transform on the command line.
Answered 08/10/2009 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity