Hi I have vendor MSI , by default ARPNOREMOVE=1 is set and i have tried to apply ARPNOREMOVE=0 through MST and CMDline but no use , i am not able to enable the REMOVE button in ARP . anybody please help me .

Thanks
Deepakkuamr
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
ARPNOREMOVE is, like ARPSYSTEMCOMPONENT, one of those properties which merely need to be present for the engine to act upon it. You could assign it a value of "antisdisestablishmentarianism" and the effect would be the same.

Remove the property in your transform.
Answered 12/09/2010 by: VBScab
Red Belt

Please log in to comment
0
i have tried this option you have mentioned , still not working is there any other way to make it work.....
Answered 12/09/2010 by: deepakkumar
Orange Belt

Please log in to comment
0
Presumably you checked the other ARPx properties...? If you did and you're still having no success, I'd venture that your transform is being ignored. Log the install verbosely and check that.
Answered 12/09/2010 by: VBScab
Red Belt

Please log in to comment
0
Try add a registry to HKLM\Software\Microsft\windows\CurrentControlset\Unisntall\App

NoRemove = DWORD=1

This will I asure you
Answered 12/09/2010 by: Rameioj
Senior Yellow Belt

Please log in to comment
0
Please re-read the first post. The OP wants to ENABLE the 'Remove' button in ARP...
Answered 12/09/2010 by: VBScab
Red Belt

Please log in to comment
0
Sorry for the confusion. Rather change the registry value "NoRemove" = DWORD, 0
Answered 12/10/2010 by: Rameioj
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity