Does anyone know what to put in place of $ticket_url so that it displays our helpdesk name instead of kbox? Right now when the email is sent it displays the following below. Instead of it saying kbox, I would like it to say our helpdesk name. Is that possible? I tried http://helpdeskname/userui/ticket?ID=$ticknum but it only took me to the user interface and not the actual ticket. $ticket_number puts the number there but also includes TICK: with it.


The body of the email in kbox settings:

Your ticket $ticket_title has been closed and we are interested in your feedback regarding your overall satisfaction with our handling of the issue.


Please visit the help desk at
$ticket_url
and submit your rating and comments.

Thank you for taking the time to improve our services to you and other users.


What the email actually shows:

Your ticket test has been closed and we are interested in your feedback regarding your overall satisfaction with our handling of the issue.

Please visit the help desk at
http://kbox/userui/ticket?ID=1208
and submit your rating and comments.

Thank you for taking the time to improve our services to you and other users.

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I'm confused... http://kbox/userui/ticket?ID=$ticknum should take you directly to your ticket. The only way you can change it to http://helpdeskname/userui/ticket?ID=$ticknum is if the hostname for "helpdeskname" resolves to the same IP as "kbox". If so, you shouldn't have any problem.
Answered 03/12/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
We have a DNS entry for our helpdesk name pointing to the same IP as the KBox name. Right now the email is setup with $ticket_url as the link that is sent to the user. This actually displays http://kbox/userui/ticket?ID=1208 in the email. Instead of the $ticket_url displaying http://kbox/userui/ticket?ID=1208, I would like it to display http://helpdeskname/userui/ticket?ID=1208. I am guessing that you cannot change what $ticket_url actually calls upon, so I replaced $ticket_url with http://helpdeskname/userui/ticket?ID=$ticknum instead. This method works great when making rules but when the email on event is sent out, it displays http://helpdeskname/userui/ticket?ID=$ticknum because $ticknum is not actually added the ticket number to the email like it does in the ticket rules. Basically, I need to add something to the end of http://helpdeskname/userui/ticket?ID= So I need to add a "variable" after ID= to place the actual ticket number there in the email on events because $ticknum does not work with email on events. Is this a little clearer at all? Or, is my mind slowly dying from this long week?
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
1
$ticknum works in ticket rules, and that's what I thought you were referring to.

The following symbols are available in all templates:
$userui_url, $helpdesk_name, $helpdesk_email

The following symbols are available in templates for email involving tickets:
$ticket_escalation_minutes, $ticket_priority, $ticket_number, $ticket_title, $ticket_url, $ticket_history, $ticket_submitter_name, $ticket_submitter_email, $ticket_owner_name, $ticket_owner_email, $change_desc


If $ticket_number spits out TICK: ####, then there is no way to accomplish your goal.
Answered 03/12/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
1
Oh, ok. Thanks for the help. I was just trying to make it all the same between the ticket rules and the email on event emails. Trying not to confuse the users anymore than they already think they are by have two different links going to the same thing.
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
0
It sounds like you want to change your "KBOX Web Server Name". We changed ours to "helpdesk" and our links, in emails sent by kbox, now show "http://helpdesk/userui?ID=1208". No changes to the body of the email were made.
Answered 03/12/2010 by: jeremys
Orange Belt

Please log in to comment
1
ORIGINAL: jeremys
It sounds like you want to change your "KBOX Web Server Name". We changed ours to "helpdesk" and our links, in emails sent by kbox, now show "http://helpdesk/userui?ID=1208". No changes to the body of the email were made.


That would work, but it would affect everyone's access to the server - unless they leave a CNAME record to point KBOX to HELPDESKNAME.
Answered 03/12/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
1
That would work but I do not want to change the actual server name. I was just hoping to make an easy adjustment to the email on events instead. Plus, we have everything setup with the kbox name and a DNS entry in for the end users. I was just trying to mainly make everything flow together and flow the same.
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
1
You can always put in an enhancement request to add the $ticknum variable to Email on Events.
Answered 03/12/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
1
Thats true. I already have a huge list of them anyways. Whats one more [:D]
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
1
It's enhancement 3491.

Specifically to the original question: wouldn't that URL still work?

Also you should always have your webservername formatted like this: http://www.kace.com/support/customer/faq/index.php?action=artikel&cat=1&id=628&artlang=en
Answered 03/12/2010 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
1
Oh so for the "Kbox Web Server Name", I should actually have our domain after it? Right now, it just displays kbox. I should add our domain to the end of it.

The link does work to a point. It will take you to the helpdesk but will not take you to the ticket. The TICK: in the link prevents it from displaying the actual ticket itself.
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
1
Hey, I got it working. Jeremys was correct. Thanks!! For some reason I thought he was talking about changing the kbox name in general. After Gerald's post, I started snooping around in the settings page (on my test box of course) and trying different things. The article he posted talked about adding your domain after the "Kbox Web Server Name". As I got to thinking, I decided to change it to my helpdeskname, which we also have a DNS entry for pointing to the kbox. By doing so, actually fixed my issue. Now the "Email on Events" is showing my helpdeskname instead of the kbox name. At that point, I came back here to look Jeremys's post over better and realized that is what he told me to do. It was in front of my face the entire time. I wish I had more time to actually really get to know the KBox a lot better as I would have known what he was talking about. I never really paid much attention to the settings area because everything was working fine. You always seem to learn the most when something breaks or you need more functionality.
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
1
Do what I do. Close your eyes, randomly click he mouse buttons and then try to fix what you just did. ;)
Answered 03/12/2010 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
1
ORIGINAL: GillySpy

Do what I do. Close your eyes, randomly click he mouse buttons and then try to fix what you just did. ;)

LOL. The devs must lock the door when they see you coming, Gerald!
Answered 03/12/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
1
That sounds like a great idea! I am going to try it out in AD first and see where that takes me lol [:D] I think that is what 85% of our end users do.
Answered 03/12/2010 by: ustacp
Second Degree Blue Belt

Please log in to comment
1
[:D] great idea, but it will also take someone to HOME [;)]
Answered 03/12/2010 by: afzal
Fourth Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity