I'm having problems getting a silent install for Dymo labelwriter to work, BKelly's post is helpful, but the problem I have is actually installing the drivers.

http://www.appdeploy.com/packages/detail.asp?id=133

have tried using devcon, but can't seem to get it to install the device properly. requirements are that I can push the software down, and have users use it without admin rights to add the device.

No matter what IDs I use I get 'devcon failed' after it copies the driver files, and tries to install the device. I can disable and enable the device, but when I use

Devcon install dymo.inf USBPRINT\DYMODYM00084379

it returns 'devcon failed'

any help very much appreciated, thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
If you send the software to my hotmail account or point me in the direction of what version you are using, I'll be happy to take a look at it for you and see where the device driver install is failing.
Answered 11/28/2004 by: MSIMaker
Second Degree Black Belt

Please log in to comment
0
Hi DuncanPaul

I use devcon, and its a bit tricky at times. Sometimes, for some reason, the same device will have more than one entry, and more than one device ID (USBPRINT\DYMODYM00084379).

What I usually do is manually install the device on a test pc and when its working, run the command:

devcon hwids * > c:\temp\devcon.txt

And then do a search for the name of the device in there, it may be it will appear in there more than one (I've had this happen)

The output will look like this:

HID\VID_045E&PID_0040\6&569E2D7&0&0000
Name: Microsoft USB Wheel Mouse Optical
Hardware ID's:
HID\Vid_045e&Pid_0040&Rev_0300
HID\Vid_045e&Pid_0040
HID_DEVICE_SYSTEM_MOUSE
HID_DEVICE_UP:0001_U:0002
HID_DEVICE


So you can see it has a few different hardware ID's, if this was what I was trying to do I'd try em all.

Hope thats helped somewhat.

Rgds

Paul

PS Bloomin heck, a "Senior Member" now... respect my authoritaaah LOL
Answered 11/28/2004 by: plangton
Second Degree Blue Belt

Please log in to comment
0
Thanks MSIMaker and Plangton, (just worked the handle out, nice work.)

have been doing as you suggest, but can't seem to work out the syntax and what devcon expects. can disable and enable using the ID USBPRINT\DYMODYM00084379, but cant seem to add the first device. I'm guessing I have to add USB Printing support, then the dymo device.

these are the devices that get installed when you manually add the device.

USB\VID_0922&PID_0008\03032606392187
Name: USB Printing Support
Hardware ID's:
USB\Vid_0922&Pid_0008&Rev_0100
USB\Vid_0922&Pid_0008
Compatible ID's:
USB\Class_07&SubClass_01&Prot_02
USB\Class_07&SubClass_01
USB\Class_07
USBPRINT\DYMODYM0008\6&5427A39&0&USB001
Name: DYMO LabelWriter 330 Turbo-USB
Hardware ID's:
USBPRINT\DYMODYM00084379
DYMODYM00084379

thanks again for your help with this.
Answered 11/29/2004 by: DuncanPaul
Orange Belt

Please log in to comment
0
Hi DuncanPaul,

Yep from the looks of things you have to do USB printing first then the other one, but I'm guessing here. I hope you have also taken up MSIMakers generous offer to have a look at it. Also note that devcon isn't the only way of doing device drivers in MSI's, MSIMaker and I have posted another way previously on this forum...

Sorry I can't be more help...
Rgds

Paul
Answered 11/29/2004 by: plangton
Second Degree Blue Belt

Please log in to comment
0
Hey thanks Paul, and yeah, I did send Jim the source, he needs another star, what a guru.
will go looking for your other device driver method now, devcon is the only way I've used in past. thanks again
Answered 11/29/2004 by: DuncanPaul
Orange Belt

Please log in to comment
0
Hi DuncanPaul,

Yep I second that, he's the go to guy :) I do my best however ...

Sorry I didn't put the link in this morning, hadn't had coffee and was a bit lazy, here it is:

https://adelie.ucs.ed.ac.uk/dstwiki/index.php/device%20drivers

Rgds

Paul
Answered 11/29/2004 by: plangton
Second Degree Blue Belt

Please log in to comment
0
Thanks Plangton, MSI method in your reference worked a treat,

just need to script the sharing of the printer, and client connections to shares.

thanks again for the help.
Answered 11/29/2004 by: DuncanPaul
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity