Hello,

When I install Autodesk DWG TrueView 2012 (x64) with local administrator account to Windows 7, .dwg file type is linked correctly to this software.

After logging with user account or other administrator account to same workstation and attempting to open any .dwg file for first time, I get error message: "There was a problem sending the command to the program", then MSI self-repair occurs and I don't get that error anymore when opening .dwg files.

How you can deploy DWG TrueView to all users without getting this error?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It seems like the reg keys for the file association are installed to:
HKEY_CURRENT_USER\Software\Classes

Check this reg path for .dwg and modify your MSI so that the reg keys are getting installed directly to HKCR.
Answered 07/14/2011 by: Teitan
Senior Purple Belt

Please log in to comment
0
@TeitanCheck this reg path for .dwg and modify your MSI so that the reg keys are getting installed directly to HKCR.You need to remember that HKCR isn't a separate branch of the registry but a merge of HKCU\Software\Classes and HKLM\Software\Classes. Where the file association gets set up depends on whether the app gets installed per-user or per-machine, one powerful reason for using the advertising tables rather than writing directly to the Registry table.

@weedee, you need to set up the shortcut (or file association) so that it's advertised. That way, the app will self-heal before the error occurs. There's plenty here on AD about setting up self-healing so use the 'Search' function.
Answered 07/14/2011 by: VBScab
Red Belt

Please log in to comment
0
Yes, i know but from my experience users dont like it if Windows Installer pops up if they want to launch an application thats the reason why i prefer writing it directly to registry instead of using adveritsed shortcuts.

But of course the way you've described is the more cleaner way.
Answered 07/14/2011 by: Teitan
Senior Purple Belt

Please log in to comment
0
Hello Teitan,

Thanks for your reply.

I opened my MST file to InstallShield Authoring Tool and checked registry entries. There's no HKCU\Software\Classes key at all in my MST file.

Instead, there's .dwg key directly under HKCR.
Answered 07/14/2011 by: weedee
Orange Belt

Please log in to comment
0
Another solution would be to create an Active Setup key which applies a reg file including the file associations.
But you should rather take a look at the extension table as VBScab said because there is no good reason to do something in another way if msi supports it.
http://msdn.microsoft.com/en-us/library/aa368571(v=VS.85).aspx
Answered 07/14/2011 by: Teitan
Senior Purple Belt

Please log in to comment
0
You need to remember that HKCR isn't a separate branch of the registry but a merge of HKCU\Software\Classes and HKLM\Software\Classes. Where the file association gets set up depends on whether the app gets installed per-user or per-machine, one powerful reason for using the advertising tables rather than writing directly to the Registry table.

[url=http://office2007use127.bloguez.com/office2007use127/2368754/Microsoft-Office-2007-Is-An-Ideal-Tool-To-Create-Better-Documentation]Microsoft Office 2007 Is An Ideal Tool To Create Better Documentation[/url]
[url=http://www.blogster.com/office2007use127/how-to-set-passwords-for-microsoft-office-2007]How To Set Passwords For Microsoft Office 2007[/url]
[url=http://office2007use127.mancouch.com/752629400/are-you-hunting-support-genuine-microsoft-office-2007/]Are You Hunting Support Genuine Microsoft Office 2007[/url]
Answered 07/14/2011 by: jerry05031111
Yellow Belt

Please log in to comment
0
Hi,

This was resolved by adding following line to ActiveSetup:

msiexec /fpu {productcode} /qn
Answered 07/15/2011 by: weedee
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity