Recently I have begun to see duplicate emails from Kace Service desk when a ticket submitter enters a comment by replying to an email for an existing ticket. The owner of the ticket will then receive two emails informing them of this new comment.The notification messages are customized, so I am able to tell that there is one "Comment submitted" email, and one "Ticket Modified" email.

A couple of months ago we upgraded our K1000 to version 6.4. Prior to that, owners would always get only a single email when a comment was entered via email from the ticket submitter. Looking at past emails, it appears this was always the "Ticket Modified" email.

Our settings for Email on Events have not changed. Owners are now, and have for the past year, been set to receive emails on: Any Change, Owner Change, Status Change, Comment, Escalation.

What would be the correct settings to prevent owners from seeing two emails when a submitters sends an email to an existing ticket? What sorts of ticket changes which are not covered by other events would be missed if "Any Changes" were not selected?
2 Comments   [ + ] Show Comments

Comments

  • It may be that the queue is now firing emails using both the "any change" and "comment" option, meaning you get the two emails. I would suggest testing by unticking one option and seeing if only a single email is sent.
  • Our testing shows that if a submitter enters a comment and the Owners Email on Comment is unchecked, the Owner does not get an email unless another field is changed at the same time. It is very frustrating, Owners get 2 emails, one from the comment email and one from the Ticket modified email or nothing at all. Hopefully Kace will fix this, it only broke after the 6.4 upgrade.
    • Elisha do you now if this was fix after the v6.4 SP1 patch. I'm having the same issue after I have upgraded to v6.4.

      Thanks,
      Jonathan
      • No it did not. Kace told me that it is now working as designed, so I guess we are stuck with the duplicate emails. I had to turn a bunch of options off under Queue Detail Configuration to reduce the amount of emails we were getting
Please log in to comment

Answers

1
Unchecking the "Comments" box seems to resolve it.  If it doesn't, please open a KACE support ticket so it can be looked into.
Answered 01/11/2016 by: jknox
Red Belt

  • Thanks, I will give that a try.
    This could be a problem for some queues, though, if the modified email does not contain $lastcomment or other information intended to be specific to comment emails, but not included in emails for "ticket modified". I've always considered it an oddity that the list of customisable emails does not match up with the list of selectable email events. This just makes it slightly more odd.
Please log in to comment
Answer this question or Comment on this question for clarity