/bundles/itninjaweb/img/Breadcrumb_cap_w.png

Hi

I am having an issue with the drivers recache on our k2000 box. I used the driver harvesting tool and loaded the drivers. when i go to recache them on the k2000 i get the following error under appliance maintenance. Error: DevicePath is too long; try flattening driver directories or reducing length of directory names.

i've checked all the folder paths and all of them are under 150 chars. i dont understand what i need to flatten.

 

any ideas?

0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Answer this question or Comment on this question for clarity

Answers

1

Remove the driverharvest folder and then add in the ini files manually to your desired folder. I would also recommend using Double Driver instead of the driver harvesting utility. http://www.boozet.org/dl.php?product=dd&mirror=2

Answered 05/13/2013 by: mpace
Red Belt

Please log in to comment
1

did you drill down to the deepest subdirectory?

open a command window on your windows tech station and connect to the kbox

run tree \\ikbox\drivers and \\ikbox\drivers_postinstall

see if you have any deep dirs you missed

 

Answered 05/13/2013 by: SMal.tmcc
Red Belt

Please log in to comment
0

thanks for the answers. i ran a program called treefile size which searched the directory and all sub directories. at first some of them were about 190 chars long, so i shortened them to less than 150 (includes the servername)

i will try and remove the harvest folder and add the ini's and see what happens.

 

thanks again

Answered 05/14/2013 by: Pete.Evans
Senior White Belt

Please log in to comment
0

removed the driver harvest folder completely and im still getting the error. I ran the tree command on all the directories and nothing is longer than the 150 chars.

anyone got any other ideas?

Answered 05/14/2013 by: Pete.Evans
Senior White Belt

  • Hmm, very strange. Have you rebooted the K2000? If not I would try that. Also be sure to run that tree tool against the entirety of the drivers share, not just a single directory.
  • thanks mpace, restarted it a few days ago and it had the issue before it restarted and still does. i got some people in my team who are due back soon so will pass it onto them.
Please log in to comment