I have a package giving me the following error.


I found the cause to be custom actions in my package calling msiexec /y <full path to dll>. The problem is that I cannot make these dialogues silent at the command line when installing a package. I found one workaround by using regsvr32 but is there a better way to make these silent?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
What's the package? I have a friend who programs in Progress, maybe he might know something.
Answered 03/16/2007 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
0
It's the progress 9.4 client but the package is a setup capture of their installer using Wise 7. I am pretty sure the message box is being generated by Windows Installer and is probably there as a security feature of some sort but it prevents a silent install. I was thinking of changing the custom action to be msiexec /y <full path to dll> /qn and see if that shuts it up.
Answered 03/16/2007 by: kkaminsk
Ninth Degree Black Belt

Please log in to comment
0
Well this: msiexec /y <full path to dll> /qn

Doesn't make it silent either.
Answered 03/16/2007 by: kkaminsk
Ninth Degree Black Belt

Please log in to comment
0
Use something like Regspy.exe or similar to extract the registration registry info and add/import it to the Registry or Class, TypeLib & ProgId tables.
If you use Wise you could try WiseComCapture.exe instead but I prefer Regspy.exe, get a feeling that it does the job better then this one.
Answered 03/16/2007 by: AngelD
Red Belt

Please log in to comment
0
The reason I am so intent on figuring out how to silence this is because I am using a combination of the setup captured com information as well as having Wise perform the self registration of the DLLs. In this case I have two DLLs that produce that message and either I change the Wise configuration for the environment, provide a workaround or find a way to silence that message box. Since Windows Installer is producing that message box I am assuming that there has to be a way to silence it.
Answered 03/16/2007 by: kkaminsk
Ninth Degree Black Belt

Please log in to comment
0
"msiexec /y" only calls the DllRegisterServer API to self-register the file so by this it feels that the DLL itself is checking this but in otherhand as you don't get this message when using regsvr32 it may not.

You can't use other parameters in conjunction with the /y switch as you can only specify "msiexec /y module".
If you want it silent you will need to capture the file association + the COM info as you already done.

Can't think of another way.

If you do find out of whom is responsible of showing the message please enlighten us or me anyway :)
Answered 03/16/2007 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity