I have an application I am creating an MST for since it already has an MSI.
The package builds and installs smoothly as long as you are the admin user.
If you are a normal user you can not see any icons in the menu but you can start the application by going into the directory and clicking on the executable.
Has anyone had this problem and found a workaround for it?
If I were using the scan method it would be easy to build icons for it but witht he MST all it does is read keystrokes.
Someone mentioned that you can do it through ORCA but I'm not familiar with that product though I can get access to it.

ej
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2
It sounds like you have a "per user" installation. You can test this by setting the ALLUSERS property to 1.
Just add ALLUSERS=1 to your commandline:

>msiexec.exe /i yourapp.msi TRANSFORMS=yourmst.mst ALLUSERS=1

If this solves your problem you can use ORCA (ORCA is like a sort of notepad for windows installer files) to add this property to the Property table.

I hope this helps.
Answered 05/10/2005 by: Ilikebananas
Purple Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You test this on the command line just before using the appname.msi to install, after a successful install you then return to installshield and open the properties section and set "Allusers=1" or you need to use ORCA to set this parameter?

ej
Answered 05/11/2005 by: erjones
Senior Yellow Belt

Please log in to comment
0
The icons are showing up now, I used 2 vice 1.
Thanks for the information

ej
Answered 05/11/2005 by: erjones
Senior Yellow Belt

Please log in to comment
0
Hey,

way cool! And so simple, of course I didn't look for the icons in the install users context...
I just added ALLUSERS 2 to the Property table right inside the msi.
This is the solution I was trying to find using the keywords missing shortcut after msi install.
So this is my post to add these keywords to the thread and to tell everybody that it worked like a charm.

Cheers,
Konstantin
Answered 07/13/2005 by: KPrinz
Fourth Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity