I'm having an issue in Win7 where a dialog box comes up and says that my Java version is out of date. Can someone please tell me how to disable this or is this a known issue? I also have the following added to my Registry & deployment.properties

deployment.javaws.autodownload=NEVER

 

 

Registry

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

Add a deployment.properties and deployment.config file to C:\Windows\Sun\Java\Deployment\

Modify the properties file to set the value deployment.expiration.check.enabled=false from true

That will suppress the expiration message that you are seeing (even though Update 40 is not expired). We started seeing the same message once 45 was released Tuesday. Even with that registry key changed from 1 to 0 to suppress updates, as you did, the expiration date is coded into Java.

You can find information about those 2 files at http://docs.oracle.com/javase/7/docs/technotes/guides/deployment/deployment-guide/properties.html

Answered 10/17/2013 by: rockhead44
Tenth Degree Black Belt

  • That page no longer exsists. Any updates with j7 u55?
  • Also appears I don't have the c:\windows\sun\java\directory
    • Create a directory & also create two files. One named deployment.config with the following content "deployment.system.config=file\:C\:/WINDOWS/Sun/Java/Deployment/deployment.properties " and deployment.properties with the following content deployment.javaws.autodownload=NEVER
      deployment.javaws.autodownload.locked=
      deployment.expiration.check.enabled=false
Please log in to comment

Answers

0

This worked for me & i really appreciate for your help.

Answered 10/17/2013 by: chichora123
Fourth Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja

Share