I've been having a problem with WoL on some of our new systems, and it turns out that the cause is the Energy Efficient Ethernet option on the Intel NICs. When the PC was shut down recently, I can wake it without a problem, but if it's been shut down for a while or is in standby, the NIC shuts down and doesn't respond to the magic packet. Disabling the EEE option looks like it will solve the problem, but I really don't want to touch every machine to make this change if I can help it. I've looked at PROsetcl.exe, but this feature doesn't seem to be listed as a changeable option in the command line. Does anybody have any idea how to script this change?

 

Thanks!

Jon

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

I got the right answer after posting the same question on Intel's cummunity forum, although it's still hit and miss:

 

Command:

PROSETCL.exe Adapter_SetSetting <AdapterIndex> EEELinkAdvertisement 0

 

Example:

 PROSETCL.exe Adapter_SetSetting 1 EEELinkAdvertisement 0
Answered 06/12/2012 by: JonHall
Orange Senior Belt

Please log in to comment

Answers

0

I want to say that this is possible thru WMI. Take a look at at Win32_NetworkAdapter.

Answered 04/16/2012 by: dchristian
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity