I have an issue with a large msi, repackged with WPS 5.6, on install I get error 2705, invalid directory table. Usually I've had this, and then when you look in the directory table there are funky rows, or obviously incorrect entries.

Unfortunately with this app, I have 420 entries in the table, making manually checking them pretty difficult. I've attempted to do it with excel, but can't seem to find whats broken.

SO.. has anyone a tool for finding directory table errors?
I've tried enabling verbose logging and don't get any more information, just 2705 invalid directory table, could not be linked as tree.

additional info: app is Rational TestTeam, is a network install, and also does some odd stuff during install, such as tries to write back to the share (this may be cause of issue?).
Another odd thing is that a lot of the folders in the app are named something.something.etc , I wondered if this is messing it up as . can be used to signify no subdir?

any help much appreciated.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Apologies,.. . have resolved it. directory table was in fact full of rubbish, uncovered by dumping table into excel, then doing a vlookup to find parents without child directories.
Answered 10/03/2005 by: DuncanPaul
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity