I am using the Office 2003 Custom Installation Wizard to generate new MSTs for Office 2003 Standard and Professional (we use both packages). I am generating a separate MST for standard and one for Professional. When I get to the "Change Office User Settings" page, I go to Office Excel 2003 --> Tools | Macro --> Security and modify the setting for "Trust access to Visual Basic Project". I change the setting to turn it on. When I deploy the Office standard with my standard MST, I get into Excel, go to Tools --> Options --> Security --> Macro Security, Trusted Publishers tab. The "Trust Access to Visual Basic Project" is checked and I am able to change it manually if I want. When I deploy my professional package with the professional MST, the "Trust Access" box is checked BUT it is greyed out. I cannot figure out how to un-grey it.

Before you ask, we have an in-house written app that requires low security and the Trust Access to VB checked. Yes, this is not very secure but it is the only way we can get the app to work.

Does anyone know why this setting works differently between standard and professional and how I can make them work the same?
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Use a lightweight snapshot tool like InstallWatch to capture the change that happens in Standard. It's almost certainly a registry value. Then you can compare that to a Pro set-up and work from there.
Answered 08/14/2009 by: VBScab
Red Belt

Please log in to comment
Thanks. What I found was MS apparently changed the way it worked between the standard and professional editions. To keep it functioning the same between both editions, I added two registry keys:

HKCU\Software\Microsoft\Office\11.0\Security\AccessVBOM - double word - set to 1 (this is for the Access to Visual Basic)
HKCU\Software\Microsoft\Office\11.0\Security\Level - double word - set to 1 (this is for using the low macro security setting)

I had to delete two keys:

Answered 08/17/2009 by: dadman53
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity