i created a desktop wallpaper using the configuration tool and deployed it to a test PC. It requires a restart to app;y the desktop background but after a couple of reboots it goes away and the screen is black and it only works on one user. how can i get it to stay and set for all users. 
any suggestions. Here is the script i used

Verify

  1. Verify that “HKCU\Control Panel\Desktop!Wallpaper” is equal to “$(KACE_DEPENDENCY_DIR)\iamaredraider-1024x768.jpg”.
    trashcan-icon.png
  2. Verify that “HKCU\Control Panel\Desktop!TileWallpaper” is equal to “0”.
    trashcan-icon.png
  3. Verify that “HKCU\Control Panel\Desktop!WallpaperStyle” is equal to “2”.
    trashcan-icon.png
  4. Verify that “HKU\.DEFAULT\Control Panel\Desktop!Wallpaper” is equal to “$(KACE_DEPENDENCY_DIR)\iamaredraider-1024x768.jpg”.
    trashcan-icon.png
  5. Verify that “HKU\.DEFAULT\Control Panel\Desktop!TileWallpaper” is equal to “0”.
    trashcan-icon.png
  6. Verify that “HKU\.DEFAULT\Control Panel\Desktop!WallpaperStyle” is equal to “2”.
    trashcan-icon.png
thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

3
I would recommend using Group Policy to set the wallpaper, if possible. Since KACE is setting the registry key for the current user it will only apply to that user and not all users on the system. Group Policy would apply to all users.

Answered 04/16/2015 by: chucksteel
Red Belt

  • I haven't tried it, but according to this webpage, setting "WallpaperStyle" in HKCU sets it for all users: http://www.sevenforums.com/tutorials/62048-desktop-background-specify-prevent-change.html
Please log in to comment
Answer this question or Comment on this question for clarity