Hi...I am trying to package Google Drive.The problem is that there is no desktop shortcut in the package but once I launch the package for the first time after installation, it creates a desktop shortcut.This shortcut points to C:\Users\"myuserid"\GoogleDrive.....I need to prevent the creation of this shortcut on first launch.I tried deleting the shortcut manually and re-launching the application.It doesnt create on 2nd launch.The issue is just with the first launch.Please assist.

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2

Capture the changes when you launch the shortcut for the first time.. The reference will be stored in the <USERPROFILE>. Include the same as part of the package.

Answered 04/23/2013 by: jagadeish
Red Belt

  • The reference will be like, whether the Desktop shortcut has been created or not.. If it says yes then next time the shortcut will not be created on desktop when you launch the shortcut from the startmenu ->programs
  • Not able to understand how that would help me...Even though I capture the changes and include it in my package....This time shortcut will be created on desktop when I install it as this time it would come via Package installation(unlike earlier when it was coming due to app launch)
  • When you launch the shortcut for the first time, It will update a file in UserProfile folder saying that the shortcut has been created on Desktop. You no need to include that shortcut in your package. you just to directly update that file..that the shortcut has been already created.. so next time when you launch the application.. Desktop shortcut will not be created though you don't have any shortcut on desktop..
  • For Google Chrome.. There is a 0 KB file named "First Run" without any extension in the below location

    "C:\Users\<USERPROFILE>\AppData\Local\Google\Chrome\User Data\First Run"

    If this file is there then the Desktop shortcut will not be created automatically when you launch the Strat Menu-Programs shortcut..

    Like this.......
  • Thanks for ur answer...will try that :)
Please log in to comment

Answers

1

The whole point of the Google Drive synchronization tool for the PC/Mac is to allow you to access documents stored in Drive when you are not signed in to that account or even online.

If you don't want that to happen, do not install the app, and just use Drive online when you are signed in.

Answered 04/23/2013 by: SMal.tmcc
Red Belt

  • This is a great answer to a different question :D http://productforums.google.com/forum/#!topic/gmail/1Pah4mqt08s
Please log in to comment
1

First you need to find out how this shorcut is getting to the desktop. Do this by installing it on a clean machine, clearing the application event logs, and then starting Google Drive from start menu I assume?

Once the desktop shortcut is created, check the event logs. You are checking to see if the MSI creates the shortcut (through an advertised entry point), if it did, there will be MSI event logs.

If this is the case, hunt around for a possible CA in the MSI. This is assuming there is no shortcut in the shortcut table.

*This is not a sure fire way of checking, just what tumbled out of my head first.

 

The other way the shortcut can be created, it could created by the google drive application itself which is more likely. If this is the case, there isnt much you can do about it, unless you would like to rewrite the google drive app.

 

Hope this helps, Riley.

Answered 04/23/2013 by: rileyz
Red Belt

  • I tried what you said but I think this is due to app behaviour and cannot do much about it.
Please log in to comment
1

this looks promising.  http://productforums.google.com/forum/#!msg/chrome/9RCMss6nBPQ/m7965zmyc7gJ

Perhaps you could include this first run file and "inject" it yourself.  It seems it's existence prevents the shortcut.

Answered 04/23/2013 by: GillySpy
Seventh Degree Black Belt

  • @GillySpy : i tried looking for this preference file in GoogleDrive INSTALLDIR but could not locate any such file.Also checked in Google Drive settings and couldn't find anything that could disable this shortcut.
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment
Answer this question or Comment on this question for clarity