Hello there,

i`ve got problems with this 3 programms while doing a silent installation via k1000.

If I want to install the pdf creator (4.9.0) with the /silent or /verysilent switch,  the setup won`t uninstall the old version (4.6.0) and don`t installs the new version. But if I install the setup manually the setup works as it should and i`ve got the Version 4.9.0 on the softwarelist in windows.

Pidgin also don`t installs cause the old version is still running and the setup won`t cancel that running process. (only while using /S switch, otherwise it works normally)

My last problem ist similar to the others: while installing Tortoise the setup needs to stop the explorer.exe process and at the end of the setup it restarts that process again. The problem is that the setup don`t starts the explorer.exe at the end again while using /quiet /i switches.

any ideas?

thank you.

 

 

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1

Try running the installs using psexec to make sure it doesn't need admin rights to perform the uninstall/upgrade install: http://www.kace.com/support/resources/kb/article/how-to-mimic-running-a-script-as-local-system-user-scripting

If it needs admin rights, switch to an online script and use "run as" to provide admin rights.

Stopping the service will probably either require a batch file to stop the service and then run the install, or in a script, stop the service and use the "install a software package" task.

Answered 09/11/2012 by: jknox
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity