Hi,

I'm trying to deploy Nero 7 using Zenworks 6.5 but as it seems I have a problem with my package.
I get an error "AdvrCntr2D6E0B790.dll could not be found in any cabinet". I checked the cabinets and the file is there as it should be! Had somebody the same error?
Here some details from the log file :
08:15:47 DEBUG: GetUserInterfaceLanguage(): LangID = 1033 Lang = ENG
08:15:47 DEBUG: Setting property 'UI_LANGUAGE' from ' to 'ENG'
08:15:47 DEBUG: Setting property 'UI_LANGID' from ' to '1033'
08:15:47 DEBUG: GetRegisteredUserFromCommandline started...
08:15:47 DEBUG: GetRegisteredUserFromCommandline done
08:15:47 DEBUG: SetSerial started
08:15:47 DEBUG: ExtractFromCab: Extracting AdvrCntr2D6E0B790.dll from CAB Cab\307C0B60.cab
08:15:47 DEBUG: GetSourceDir failed.
08:15:47 ERROR: AdvrCntr2D6E0B790.dll could not be located in any cabinet. 1400
08:16:19 DEBUG: Could not access advertisement center.

Install continues but fails after some time with standard MSI error 1603. The logs show that it's due to the missing file.
Has anyone a workaround?
Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi there,

Seems like the installation is having problems resolving the source directory.
If the installation can't resolv the source directory it probably won't be able to find your cab-files either.
> 08:15:47 DEBUG: GetSourceDir failed.

If you install the MSI without using ZENWORKS, does it install OK?
Maybe you've not supplied the full-path to the MSI?
(Know nothing about zenworks... so this is just a thought)



peska
Answered 06/27/2006 by: peska
Senior Yellow Belt

Please log in to comment
0
Hi,

I get the same error message ("AdvrCntr2D6E0B790.dll could not be found in any cabinet") when I try to install Nero 7.2.0.3 without any deployment tool.
(e.g. msiexec /i "nero.msi" TRANSFORMS="1033.mst" STARTPARAM="CallFromExe" DONOTRUNSETUPX="1" /qb)
My log file looks similiar.

But now the real interesting thing:
This error just appears with "/qb". If I try to install nero using /qr it works without any error messsage.

The problem is, that a possible user interaction while installing any software is not permitted in our company. And using /qr will allow the users to change the file associations, shortcuts ...

That's my problem. Sorry for my strange English. I hope, someone can help us.

Thanks in advance
Answered 07/06/2006 by: abr
Yellow Belt

Please log in to comment
0
Hi,

how do you deploy your app via zenworks?

do you have a "Wrapper" for your msi or do you put your msi in the msi section of Zenworks?

If you use the msi section, there will be no userinteraction with that installation. You just get the
Distributing Application Window and thats it. You can even make that hidden, or am I missing something?

We put msi files in that section, add the properties, define the run options (normal or system user) and
Zenworks than adds the proper switches (somehow...)

regards
martin
Answered 07/06/2006 by: laszlo
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity