/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Hi Everyone,

Instead of wrapping an installshield exe, I am using it natively and created an answer file ISS to deploy some drivers.
Manual install, I execute setup /s /f1:"c:\temp\setup.iss" and works a treat.

In SCCM, I read somewhere that /SMS was supposed to fix this by placing the files locally somewhere temp to execute....
So I included the /SMS but did not work...? Am I doing something silly? [:o]

I know that I could use a vbs / wisescript to deploy it.....any other ways available?
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
You could try with:

setup.exe -s -f1%cd%\setup.iss

The %cd% tells SMS to look in the current directory - i.e. where setup is being launched from - the Current Directory.

Hope that helps,

Dunnpy
Answered 07/04/2011 by: dunnpy
Red Belt

Please log in to comment
0
Hi Dunnpy,
I gave it try setup.exe /s /f1"%cd%\setup.iss" and the execmgr log shows
Script for Package:CXS0007E, Program: Install failed with exit code 2147753984.
The advertisement log shows an error "Message ID 10006.
The program for advertisement CXS0007E failed. A failure exit code of -2147213312
The working directory shows the correct working directory in the local cache.
If I execute the command as copied from the log to the command prompt, works fine manually.
I am just awaiting to reimage the machine....
Does anyone think that the command with /SMS work? I had seen that /SMS is case sensitive.
But then again, I hear that I do not have to stipulate the /f1 due to the setup.iss residing in the same dir but that does not seem to work...
setup.exe /s /SMS /f1"%cd%\setup.iss
Answered 07/04/2011 by: tron2ole
Third Degree Blue Belt

Please log in to comment
0
I have gone to the setup capture in Wise and disregarding the Installshield stuff.....ugly anyway.
Now I can deploy a nice MSI that will be ICE ready.
Answered 07/04/2011 by: tron2ole
Third Degree Blue Belt

Please log in to comment
0
-SMS

Prevents a network connection and Setup.exe from closing before the setup is complete. This switch works with setups originating from a Windows NT server over a network. Please note that SMS must be uppercase; this is a case-sensitive switch.

You could try a batch file with

%~dp0setup.exe -s -SMS -f1%~dp0setup.iss

The above may help - the other option is to use the SMS variables %SMSDP%, which will refer to the distribution point you're running from. There are other variables, but I can't recall them at the moment :)

Hope that helps,

Dunnpy
Answered 07/05/2011 by: dunnpy
Red Belt

Please log in to comment
0

If you put the setup.iss in the same folder as your source setup.exe and use setup.exe /s as your command-line, it should look for the .iss file in the current folder and run without a problem.

If you have a differently named .iss file (sometimes necessary for different configurations or an uninstall) just use .\ for current directory.

Setup.exe /s /f1.\setup2.iss

Answered 05/08/2014 by: DeQuosaek
Senior Yellow Belt

Please log in to comment