Hi!

I have a problem.

For like a year or so I rolled out Office 2007 Pro Plus at the company (500+ users).

I customized the installation using OCT to only install Word, Outlook, Excel and powerpoint because that was the needs when we rolled it out.
Anyway, now we also need infopath.
I dont want to let every user go to the control panel/add or remove programs and add the infopath feture (can be admin rights problems as well).
I want to push this out to all users.

I have tried to do a new MSP file using OCT that only installs infopath. But it seems that you only can use this to a computer that dont have any previous Office 2007 installation.
I have tried to only install publisher using the MSI file for infopath but it dont work.

I have tried to capture only the infopath installation using Wise and create a MSI file. But that dosent work.

How can I push this out to all users?

Thanks in advanced!

BR
Eric
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Did you use a configuration XML file, too? I think you need to, in order to specify what "feature" [sic] you're going to add.
Answered 11/15/2011 by: VBScab
Red Belt

Please log in to comment
0
In my current Office package Im using the config.xml file.
And it looks like this:

<Configuration Product="ProPlus">

<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />

<!-- <Logging Type="standard" Path="%temp%" Template="Microsoft Office Professional Plus Setup(*).txt" /> -->

<!-- <PIDKEY Value="XXXXXXXXXXXXXXX" /> -->

<!-- <USERNAME Value="Customer" /> -->

<COMPANYNAME Value="XXXXXXXX" />

<!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> -->

<!-- <LIS CACHEACTION="CacheOnly" /> -->

<!-- <SOURCELIST Value="\\server1\share\Office12;\\server2\share\Office12" /> -->

<!-- <DistributionPoint Location="\\server\share\Office12" /> -->

<!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->

<Setting Id="Reboot" Value="never" />

<!-- <Command Path="msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->

</Configuration>

My whole commandline looks like this in our software delivery system:

setup.exe /adminfile ProPlus.WW\OfficeInstall_New_OUTL_Profile.MSP /config ProPlus.WW\config.xml
Answered 11/16/2011 by: aXz
Blue Belt

Please log in to comment
0
<!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->Don't quote me but I think you need to create a new XML file and specify InfoPath's Feature name - exactly as it appears in the MSI - where it says "OptionID". It would be too much to expect Microsoft to use the word "FeatureName"...

Obviously, you need to remove the 'comment' tags.
Answered 11/16/2011 by: VBScab
Red Belt

Please log in to comment
0
Thanks VBScab,

So is it enough to install like this:

setup.exe /config ProPlus.WW\newconfig.xml

Where the newconfig.xml file looks lik this:

<Configuration Product="ProPlus">

<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />

<!-- <Logging Type="standard" Path="%temp%" Template="Microsoft Office Professional Plus Setup(*).txt" /> -->

<!-- <PIDKEY Value="XXXXXXXXXXXXXXX" /> -->

<!-- <USERNAME Value="Customer" /> -->

<COMPANYNAME Value="XXXXXXXX" />

<!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> -->

<!-- <LIS CACHEACTION="CacheOnly" /> -->

<!-- <SOURCELIST Value="\\server1\share\Office12;\\server2\share\Office12" /> -->

<!-- <DistributionPoint Location="\\server\share\Office12" /> -->

<OptionState Id="XDOCSFiles" State="absent" Children="force" />

<Setting Id="Reboot" Value="never" />

<!-- <Command Path="msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->

</Configuration>
Answered 11/17/2011 by: aXz
Blue Belt

Please log in to comment
0
'State' should be "Local". As ever, TechNet/MSDN is your friend.
Answered 11/18/2011 by: VBScab
Red Belt

Please log in to comment
-2
Life is too short to wake up in the mornings with regrets. So love the ones who treat you right, forget the ones who don’t. Remember that everything happens for a reason. If you get a chance take it, if it changes your life, then let it. No one said it would be easy, they just promised it would be worth it.
Answered 11/22/2011 by: Flyingsky
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity