We've recently bought a bunch of Optiplex 7040's and I've noticed that the "Copy image from server" task is taking way longer than with other models we currently use.  When trying to image this model, when it gets to this point it initially estimates the time to take 6 hours and 50...it usually finishes in about an hour and 15 minutes, but every other Dell model I've worked with clears this step in 30 minutes or less.

I'm pulling the image down from a local RSA, both the RSA and 7040 are connected to the same switch.  I've updated by WinPE10 drivers to latest which didn't help, I've also tried downloading the network driver directly from Intel, importing that into my K2000 and making another new KBE but that also did not help.  For what it's worth, the rest of the imaging process, Applying the image, pulling down drivers, etc. seems to happen at normal speeds.

I'm hoping someone might be able to point me at a solution or work around that I might be missing.  Thanks!
Answer Summary:
0 Comments   [ + ] Show Comments


Please log in to comment

Answer Chosen by the Author

Try using our KSWIM (KACE Streaming WIM) package.  This will actually cut out the "Copying Image from Server" portion of the WIM deployment and direct deploy the WIM to the device.  When working with an RSA, make sure to sync over the originating WIM and the KSWIM version.

Answered 08/03/2016 by: andrew_lubchansky
Black Belt

  • Thank you! This worked wonderfully. After I got everything configured this took my imaging time for this model from 90 minutes plus to just under 20 minutes!
    • This will actually speed up your other deployments too!. Who doesn't want faster imaging?

      Also, make sure to check out all of the other tools on the K2000 Deployment Workbench (Tools module in your K2000). Lots of goodies and always more coming out.

      I am glad this helped you out!
Please log in to comment


We are not having any problems with the speed of 7040's imaging.  Trying adding the storage drivers also.

I downloaded, expanded and upload these for the kbe.


Answered 08/02/2016 by: SMal.tmcc
Red Belt

  • Thanks for the suggestion. I tried this and unfortunately there is no change. The "Copy image from server" task is still taking way longer than other models.
    • is your bios setting "SATA Operation" for the drive ACHI or Raid?
      • It was originally set to Raid. I just tried switching to AHCI and there was no change.
      • when you upload the new KBE are you choosing that one off the menu or did you change your default pxe boot to the new one?
      • Yes I'm using the newly created one. I haven't set it to default yet since we're still testing it.
      • just want to make sure. Connect to your kbox and copy all the drivers files from \\ikbox\drivers\kbe_windows_x64 or x86 to your tech station someplace. Delete everything in that directory and then copy only the 7040 drivers to it and try that.
      • what type of drive?
      • The drive is a M.2 512GB PCIe NVMe Class 40 Solid State Drive
      • that is probably why, you need to find the drivers from the manufacturer for NVMe drives. Others have had problems with nvme drives

      • Thanks. I see where others have had this issue, but it doesn't appear that anyone has solved the speed issue yet. I've tried importing the drivers directly from the manufacturer but that didn't help either.
Please log in to comment
I was having similar issues and talked with Dell. Using the WinPE10 drivers and Windows ADK fixed the issue. For some reason it takes a hellish amount of time on WAIK/PE3
Answered 08/02/2016 by: Keltonfoss
White Belt

  • Thanks. But I'm already using the latest WinPE10 drivers with Windows ADK.
    • This content is currently hidden from public view.
      Reason: Removed by member request
      For more information, visit our FAQ's.
Please log in to comment
This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.

Answer this question or Comment on this question for clarity