Hi,

I am having a problem, whenever I repackage any application it assign a default name to it as WinZip.... in "Product detial" and "General Information " I don't know how to get rid of it... could you guys please recommend something for this in detail.

Thanks,

Rk
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Which tool are you using?
Answered 06/09/2008 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
0
I am using wise 7.0
Answered 06/09/2008 by: dev5000
Orange Belt

Please log in to comment
0
Sounds like you by misstake added this info to the windows installer template in an earlier state.
Verify that that isn't the cause.
Answered 06/09/2008 by: AngelD
Red Belt

Please log in to comment
0
hey thanks for the reply but I didn't do anything by myself into the system ...could you please tell me where exactly i should go and check for the template... since I am very new to this tech.... I'll really appreciate if you could write all the steps needs to be followed :) thanks once again.
Answered 06/09/2008 by: dev5000
Orange Belt

Please log in to comment
0
I don't have WPS or WIS infront of me but if you look in the share point directory there should be a template directory for the windows installer template. Anything you add to this .wsi will exist in every wise project file (.WSI) you create fromout the template.
Answered 06/09/2008 by: AngelD
Red Belt

Please log in to comment
0
Yea I just checked that directry and it has couple of templates but in those templates I couldn't find anything with "WINZIP"
Answered 06/09/2008 by: dev5000
Orange Belt

Please log in to comment
0
These are stored as Summary Information properties so either open them up using Wise and look at the Summary table or in ORCA View (menu) -> "Summary Information" and check there.
Answered 06/09/2008 by: AngelD
Red Belt

Please log in to comment
0
I just checked the summary, Its giving me the repackage name which I have edited using wsi.... okay let me tell in in further detail..

1. I create a new project.
2. I took a first snapshot.
3. run the exe
4. took the second snapshot
5. exclude file/ reg/ shortcut. according to the requirement
6. when ever I hit finish,,, its start processing to create a wsi... during then It ask for the repackage name and in that window by default its showing WINZIP... I have to change the name manually... which I don't want...and why and from where it is picking up the WINZIP thing...

7. then after when ever I use wsi to edit the repackge it gives the same thing in General information and in product details.

please help me in this.

Thanks,

Rk
Answered 06/09/2008 by: dev5000
Orange Belt

Please log in to comment
0
So the ProductName property + General Information is pre-populated with WinZip after every capture, is that correct?
Verify that there isn't any bogus registry entry under (from memory) HKCU\Software\Altiris\ referring to winzip.
Still seems to me that this info is stored in your template which shouldn't be there.

The ProductName property will usually be pre-populated from the DisplayName under "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<GUID or AppName>" after the capture is done which the original installation has written, the same for the ProductVersion.
Answered 06/09/2008 by: AngelD
Red Belt

Please log in to comment
0
ORIGINAL: dev5000
I just checked the summary, Its giving me the repackage name which I have edited using wsi....

- Open the folder [WiseSharePoint]\Templates in Explorer
- Make a copy of 'Windows Application.wsi' so that, if anything goes wrong, you can restore the current state (as sub-optimal as it is)
- Open 'Windows Application.wsi' in Wise.
- In the 'Installation Expert' view,
- Select 'Product Details'
- Delete the text in the following text boxes:
'Package Name'
'Application Name'
'Product Name'
'Manufacturer'
'Version'
'Default Directory'

The other text boxes will be populated at either huild-time or when the WSI is imported into the Wise Repository.

- Select 'General Information'
- Delete the text in the 'Title' and 'Subject' text boxes
- Save the changes.
Answered 06/10/2008 by: VBScab
Red Belt

Please log in to comment
0
I am sorry but I just tried all of the above options but nothing seems to be working... any other recommendation?
Answered 06/10/2008 by: dev5000
Orange Belt

Please log in to comment
0
As a guideline do use a virtual machine (ex. vmware) when you package as it will be easier to revert to a known good state.
Instead of waste time for troubleshooting do a reinstall (remove and then install again).
Answered 06/10/2008 by: AngelD
Red Belt

Please log in to comment
0
Thanks for the reply... I am using vmware... and i did all the snapshot and stuff.. but somehow it got stuck to that.... honestly i don't know wht to do next..except for the redo wise...
Answered 06/10/2008 by: dev5000
Orange Belt

Please log in to comment
0
ORIGINAL: dev5000
honestly i don't know wht to do next..except for the redo wise...

Then why not do that then. I guess it will be quicker then for us to try to see something that isn't infront of us.
Answered 06/10/2008 by: AngelD
Red Belt

Please log in to comment
0
the only prob is my lead want me to fix without redo.:(
Answered 06/10/2008 by: dev5000
Orange Belt

Please log in to comment
0
Are you capturing fromout an created project or directly from SetupCapture tool?
If project; have you created you own project flow?
Are you sure you are using the "Windows Application.wsi" project file as the template for your captures?
Have this template in a previous stage been compiled instead of saved?
Have you ever used the template directly instead of click the New button?
Answered 06/10/2008 by: AngelD
Red Belt

Please log in to comment
0
What does the 'Template' entry in the two Wise INI's [Settings] section point to?

The two INIs are Repackage.INI which will be in the root of the share point and WisePSSC.INI which will be in your packaging machine's %SystemRoot%
Answered 06/11/2008 by: VBScab
Red Belt

Please log in to comment
0
When you select repackage option in wise,yiu need to open the current package ot the existing package which u are to re-package using wise,you have product information page where you select from drop down among the option present that you need to repackage this existing application ,there you can edit the name.

Or create a new project,then in product page it asks you in drop down number of options,there secelt repackage existing /legacy appklication ,from there you can view text box to rename the application.
Answered 07/10/2008 by: ankitabhandari
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity