Hi,

We added a date field to an asset but it pre-populated the date field with 1969-12-31 for all existing assets. Is there a way to eliminate or prevent this in the future?

Cheers,

Mike
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It is a known issue. To clean it up do the following:
  1. run a report against the asset types that were modified choosing the affected column and one other column that is unique (e.g. BIOS Serial Number).
  2. export this report as csv
  3. modify the csv to take out the report statistics (first few lines of the file -- should be obvious)
  4. Modfy the csv to take out the bad dates.
  5. import that csv back into the kbox assets (assets->asset import) choosing the same asset type. Make sure to map the columns appropriately. Flag the column (or group of columns) that combine to make each row unique as the "PK" columns.
  6. preview your import before you accept it. There should only be correct entries that are for "updation". The preview will show only changes on the relevant fields. There should be no inserts.
I suggest to try it with just one row in a csv (based on realistic data) as a test.
Answered 11/28/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity