I have two custom invetory rules to check on the Bilocker Status of a machine (one for 32 and one for 64bit machines)


ShellCommandTextReturn(C:\Windows\System32\manage-bde.exe -status c:) - 32 bit

ShellCommandTextReturn(%windir%\sysnative\manage-bde.exe -status c:) - 64 bit


These work fine on English machines and the KACE inventory for the machine shows something along the lines of:

BitLocker Drive Encryption: Configuration Tool version 6.1.7600

Copyright (C) Microsoft Corporation. All rights reserved.


Volume C: []

[OS Volume]


Size: 148.95 GB

BitLocker Version: Windows 7

Conversion Status: Fully Encrypted

Percentage Encrypted: 100%

Encryption Method: AES 128 with Diffuser

Protection Status: Protection On

Lock Status: Unlocked

Identification Field: None

Key Protectors: 


Numerical Password




but on foreign machines (for example German) the text is truncated to the first foreign character (in this case it is a ü)


The kdeploy.log on the machine shows the below information:

[Tue Sep 04 13:04:13 2012] KDeploy    Item 16964: Results=True Raw=';16964:BitLocker-Laufwerkverschlsselung: Konfigurationstoolversion 6.1.7601


Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.




Volume "C:" [System]






    Gr”áe:                    297,99 GB


    BitLocker-Version:    Windows 7


    Konvertierungsstatus:     Vollst„ndig verschlsselt


    Verschlsselt (Prozent):  100 %


    Verschlsselungsmethode:  AES 128 mit Diffuser


    Schutzstatus:             Der Schutz ist aktiviert.


    Sperrungsstatus:          Entsperrt


    ID-Feld: Kein




        Externer Schlssel


        Numerisches Kennwort


        TPM und PIN


But in the KACE admin console it is truncated to BitLocker-Laufwerkverschl [string]


So it appears to be getting stuck when it gets to this work Laufwerksverschl(here)üsselung


Does anyone have any ideas on how to get around this?


Answer Summary:
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


I would submit this to techinical support. It may be a bug in either the display or the database. Try creating a report that includes the custom field and see if it displays correctly there. Even better, if you have a tool like MySQL Workbench you can see what data is actually uploaded to the database.

Answered 09/04/2012 by: chucksteel
Red Belt

  • It doesn't display in a report for the custom field either, I do have MySQL Workbench but unfortunately I don't have a clue how to use it

    I have submitted it to technical support but they seem to take days to get back to me
  • Have you configured MySQL Workbench to connect to your KBOX? It should be as simple as entering your KBOX hostname and the username and password that are setup in Settings, Control Panel, General Settings (also be sure the enable DB Access in Settings, Control Panel, Security Settings).

    Once that is setup, browse the ORG1 tables (assuming you only have one organization) and view the data for MACHINE_CUSTOM_INVENTORY. You'll need to know the ID for the custom inventory rule you created (visible in the URL if you're using adminui) and that will help you find it in the table. For instance, if the ID for your custom inventory rule is ID 23087 the following query would show the results for all computers that have that field:


    Alternatively you can search for a specific machine using the ID field:


    This will show all of the custom inventory fields for machine with ID 28.
  • Thanks for that. If I query:


    483 is a German Machine

    Then i get STR_FIELD_VALUE = BitLocker-Laufwerkverschl and that is all so it looks like it hasn't uploaded the full information from the ShellCommandTextReturn to the database

    I logged a call with KACE support but so far I have just been given an International License to try instead of the English only one that we had but this has made no difference
Please log in to comment



KACE support had to make a change to the PHP code to fix this

Answered 09/13/2012 by: martynryan1
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity