DHCP Server & K2000 is in the same subnet, DHCP Server 172.16.1.100, K2000 Server 172.16.1.199

1. If client is in the 172.16.1.x subnet, deployment is ok.

Now testing the client in other subnet 172.16.2.x, still in the LAN, so customer don't want to you RSA.
There is no network control between the subnet & previously Symantec Ghost & MDT works well. (DHCP Relay has already been setup)

Now client machine in 172.16.2.x boot, PXE works well, get the KPE menu from K2000 server.
When boot to kgetdhcp 66 1>X:\windows\TEMP\kbox-ip-address, ERROR: Unable to determine server IP address from DHCP

Then I terminate the batch job, interesting happen:
1. I check ip address, it is the right ip address 172.16.30.153, assigned from the DHCP server 172.16.1.100
2. Manually kgetdhcp 66, no data
3. ipconfig release & renew
4. Check ip address, the address is still 172.16.30.153, which means DHCP works well.
5. Again kgetdhcp 66, "172.16.1.199", get the value

So the question is why the first time kgetdhcp get noting, however, once ipconfig release & renew, the same ip address, kgetdhcp get the value? I think there's no network configuration error there, and if the first time kgetdhcp can get the 66 address, it can works.

Need suggestion!!!!!

BTW, 244 Option has also been tested, doesn't work.

Daniel Zhou
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Daniel, Try changing the network bringup delay to higher than 15 seconds. You will need to create a new kbe to test but this could resolve your issue.

Corey
Answered 02/08/2012 by: cserrins
Red Belt

Please log in to comment
0
Hi, Corey, it sounds good, where and how to set the network bringup delay? Can you advise on that? I'll let the customer try that. Thanks for your kind respond!

Daniel
Answered 02/08/2012 by: zhoda02
Orange Belt

Please log in to comment
0
settings and maintenance and then general settings you will see the option.
Answered 02/08/2012 by: cserrins
Red Belt

Please log in to comment
0
Corey, I got that option, and I'll let the customer try what you suggested, hopefully it will help. Actually I do think it should be related, since ipconfig/release & renew then kgetdhcp works. Originally I just hope sb. can help me know more on the workflow of kgetdhcp, anyway, thanks a lot for your professional suggestion, feedback you once tested, thanks again!

Daniel Zhou
Answered 02/08/2012 by: zhoda02
Orange Belt

Please log in to comment
0
Kool! Dear Corey, your kind suggestion is completely right! The customer can deploy image with your idea, great & thanks for your kind help!


Regard
Daniel Zhou
Answered 02/08/2012 by: zhoda02
Orange Belt

Please log in to comment
0
Daniel, glad it worked, what network bringup delay value did the customer use to resolve the issue?
Answered 02/09/2012 by: cserrins
Red Belt

Please log in to comment
0
Hi, Corey:

I just let him try 40 seconds, it works. Not test other numbers.

Previously I ask local support for help, the answer is a little bit unreasonable, which suggest customer to put RSA in every subnet. Actually before kgetdhcp get the K2000/RSA address, I think the communication between K2000/RSA and client should not be established.

So really appreciate for your good suggestion. With this, technical barriers are cleaned and futher more it will help the selling a lot![:D]

Regards
Daniel Zhou
Answered 02/09/2012 by: zhoda02
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity