Has anyone had any experience repackaging Cramm V Express - it some software that comes with a Sentinel USB dongle to make it run. I have captured the software, and it installs OK, but will not run - saying dongle not present, even though the USB device is plugged in and recognised in device manager.

Through trial and error, I can safely say that Wise v6 is not correctly capturing the install to make the USB device work, having tried snapshot and smartmonitor combined. I have tried enabling detecting hardware registry changes, and also included all files detected during the snapshot, but no luck.

Has anyone repackaged such software with USB dongles and is there any files or registry keys you needed to include to make it work?

Appreciate any suggestions,

Matt
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I think the sentinal driver is already an msi you can extract and just transform..
Answered 04/17/2007 by: Tone
Second Degree Blue Belt

Please log in to comment
0
That is true. However , the software I'm repackaging already includes the drivers for the usb device. The device installs OK, is detected in device manager. I even tried installing the latest drivers but the 'no dongle present error' still occurred.

I have also contacted Sentinel, tried sentinel medic and it it saying the usb dongle is installed and working correctly, therefore the problem must be with the application itself.
Answered 04/17/2007 by: mattyskinner
Senior Yellow Belt

Please log in to comment
0
I think I packaged the driver for a different application, does it make any difference if the dongles not in when drivers are installed?
Answered 04/17/2007 by: Tone
Second Degree Blue Belt

Please log in to comment
0
Not sure - I can try that, but if you install the application manually from their install.exe the dongle doesn't have to be in first, you can plug it in later and the application works. Guess its another thing to try. My only other option seems to speak to Cramm directly.

Sorry - just re-read your post. I'm creating the app without plugging in the USB dongle. I was thinking of trying the reverse
Answered 04/17/2007 by: mattyskinner
Senior Yellow Belt

Please log in to comment
0
Sorry wasnt very clear can you install your package and then plug dongle in.. and try a reboot inbetween if that doesnt work..

I also had an issue with a dongle where I had to kill the Add\Remove wizard to ensure driver installation was successful..
Answered 04/17/2007 by: Tone
Second Degree Blue Belt

Please log in to comment
0
Cool - yeah I'll try plugging teh dongle in during the snapshot and see what happens. Thanks for your suggestions
Answered 04/17/2007 by: mattyskinner
Senior Yellow Belt

Please log in to comment
0
Has anyone else out there packaged Cramm? Tried introducing the dongle during snapshots, etc and still no joy. Has anyone got any other suggestions? please!
Answered 04/18/2007 by: mattyskinner
Senior Yellow Belt

Please log in to comment
0
is your issue only when the user plugs in the usb device ?

or actually when the device is installing ?
Answered 04/18/2007 by: jmcfadyen
Fifth Degree Black Belt

Please log in to comment
0
The issue is with the program itself. When you start the application it says the dongle is not present even though it is plugged in and detected and installed correctly with the correct drivers. The sentinel 'medic' program also states the dongle is working fine, so the issue is with the application. Some internal logic with the program, or something during the snapshot, is being missed.....
Answered 04/19/2007 by: mattyskinner
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity