Hello;  I am new to the Kace 2000 and trying to set up imaging.  My KAce 2000 is located at a hosted Data Center and is on IP range 192.168.x.x, the computers that need to be imaged are on an IP range of 172.25.x.x.  In DHCP (172.25.x.x)  "Scope Options" I have added 066 Boot Server Host Name to the K2000 IP address and option 067 Bootfile Name to K2000.0.  I have also checked DNS and ensured that my K2000 is listed.  My issue is when I PXE boot a machine at my office it times out and is unable to find the Kace 2000 server.  What am I doing wrong?

 

Thanks in Advance.

 

Scott

Answer Summary:
I took option 60 off and only have 66 and 67 enabled and that worked.. Sorry for the confusion, but at least I know the workings of it now.. Thanks All, so sorry for the extra work..
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

If you create a boot stick or cd does that connect to the k2000?

Answered 01/24/2013 by: SMal.tmcc
Red Belt

  • if you are using MS DNS put the options under the scope not the server. also try option 244
  • Yea, the options are under the scope, I will try the option 244
  • You may be be seeing it but It could be a password issue connecting to the box. have you tried creating another boot device from this same boot env and see if it reaches the kbox. This will rule out problems with your boot setup.
  • Do you get the imaging main screen or a open command window or does it not get that far?
  • it does not get that far, it stops after looking for DHCP address
    • You see an IP? If yes this could also be a bios problem there is a rash of newer bios's that cannot pxe boot to any tftp server not just kace.
      • it also affects non dell machines, it is based on an update from intel of the chipset
        http://www.itninja.com/blog/view/bios-pxe-boot-issues
      • No, it does not display an IP that it's looking for.. all our PC's are Dell's
      • we have E5530's
      • but the BIOS version is A07 which should be good
  • If there is a firewall somewhere in between verify the correct ports are open for you
    http://www.kace.com/support/resources/kb/article/network-ports-needed-for-k2000-appliance-operation
  • we do not have a firewall between them..
  • If you download a CD or USB copy of your boot environment (on your K2000... under deployments, Boot environments. Select your KBE of choice and then create your media of choice) are you able to get to your K2 that way? Some of our sites had some very strange behavior when PXE booting to K2 extenders (since resolved), but this eliminates the need by providing the boot environment locally.
  • if you are not getting an Ip it is most likely a dhcp problem or your wireless nic is on and causeing some wierd switching problem, disable the wireless nic and try the boot again
  • I know I am harping on this but create a boot device so we can then look under recovery at the ip stack and see if it is a driver problem or something else. this will also eliminate the bios as a problem.
  • OK, so I've booted to USB with no issues... thoughts?
    • When you are booted with the USB from the main menu choose recovery and open a command window, do ipconfig and make sure the machine has an ip, this eliminates a nic driver problem if you do have one.
  • Sorry it took so long to respond SMal.tmss, yes, after a USB boot, I do an IP config and have a correct range for the IP address.
    • no problem, do a net use command see if you have drives connected to the ikbox. also confirm this is the Default k2000 boot env on the Setting & Maintenance - Control Panel - General Settings.
  • OK, net use shows T:\\192.168.0.93\pretemp and Y:\\192.168.0.93\preinst, whis is my primary IP for K2000
    • That means that the boot env you made the stick from is good, has right driver and password in it. You may have to put a sniffer on this connection to see what is up. The other factors you said are right:
      dhcp scope settings, no acl/filrewalls, also confirm you have the k2000 setting as I mentioned above setup. Can someone test boot a laptop on the subnet the server is on or is that out of the question?
  • unfortunatly not, as the server is at a hosted site, but I just booted again without the usb and got "PXE-E55 ProxyDHCP service did not reply to request on port 4011" so I am going to research that and see if I can narrow down some.. Maybe a switch inbetween is not configured correctly?
    • did you check also for the option 60 like mpace mentioned on the dhcp server or in the scope. if you have it enabled turn that option off. We have only these options 003 -router, 006 dns, 015 dns, 044 wins, 066 boot serv, 067 bootfile, 244 kace option
  • Shoot.... that was it, I took option 60 off and only have 66 and 67 enabled and that worked.. Sorry for the confusion, but at least I know the workings of it now.. Thanks All, so sorry for the extra work..
Please log in to comment

Answers

0

Are you coming from another solution? Previous Altiris customers often have option 60 still defined which will stop K2 PXE booting. Additionally if you have any other appliances broadcasting for PXE on that subnet it will override the K2. You might try logging into the K2 WebGUI and clicking on the green Help button in the upper right corner, choose Troubleshooting, and try to ping a 172.25.x.x address. Something in the networking configuration might be blocking TFTP requests between those two scopes.

Answered 01/24/2013 by: mpace
Red Belt

  • mpace, I can ping from K2000 to that range, we were using WDS, but have stopped services
    • Try the USB or CD method outlined in comments above. Also try setting your DHCP timeout to 60 in Settings and Maintenance > General Settings,
Please log in to comment
0

Have you tried creating a new boot environment after updating the KBE drivers?

Answered 02/04/2013 by: Timi
Seventh Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity